URL Merge Condition issue

I’ve create a model that access a rest service created in Salesforce. I’m able to retrieve all data from the model without issue. The problem I am having is that whenever I attempt to use a URL Merge Condition based on the Service URL Skuid seems to break.

Whenever I attempt to preview the page I get a dialog box for the parameter field but there’s no way to enter the parameter.

When I try to view the page Skuid page instead I receive an error message that states the error text can’t b e found.

At this point I’m stuck. Any help you can provide would be much appreciated.

Did you make your URL Merge Condition Filterable ? It will need to be filterable and have a unique Name in order for Skuid to ask you to populate sample merge variable data for it.

Hey, Zach. I just changed it to Filterable and it’s behaving in the same manner. 

If you are actually trying to pass a page parameter value into your REST model as a condition - you need to name the Parameter.


If you are using an action framework sequence to pass a value into the REST model condition then you need to leave the value “Blank”  (making it filterable)  and use the action type “Activate Condition and pass Value” 

Hopefully these work for you. 

Hey, Rob. I’m passing in the parameter value into the REST model and still no luck. I feel like I’m missing something small but I can’t seem to find it. I’m still getting the strange error below and the filter doesn’t seem to have any effect on the returned records.

Hey John,

Try entering the “Name” of the record you’re trying to preview, and see if an autocomplete dropdown appears. If it does, pick a record from the autocomplete and then click Go.

Hey, Zach. The autocomplete drop down doesn’t appear. I did find out that the Service URL needs to be in this format for our REST service:


I got that to work but the preview still doesn’t work. But, I’m in much better shape now.

Thanks for your help.

Good to hear. Strange that the preview isn’t working, we’ll have to take a look at that.