Table Export Options DateTime field

I am appending the columns that are included in table export.

I have a DATETIME SF field and I created a UI-only field that is a formula to convert the SF DATETIME field to a DATE value.

When I view the UI-only field in the table it is showing just the date. When I bring the ui-only field into the Export Column options and download an excel the date is being printed as a DATETIME.

Any thoughts?



I am having the same issue. I tried Templates and had the same problem.

I ended up creating a SF formula field but using the UI field would be nice since it isn’t necessary to dedicate a field to this.

I got the UI-Only field to work by setting it as a Formula with text output and this formula:


Hey Tony,

I’m having the same issue. However, when I try to change my UI-Only to a ‘text’ formula, the data in my table changes to 12/31/1969. Note: The field I’m trying to view and export is called From__c and its alias is “MeterFrom”. If I put the alias name in the formula (which is what I assume I should be doing), I can’t even load the page. When I put the From__c into the formula that’s when I get the 1969 date. I should also note that I’m doing all this on an aggregate model.
Is CreatedDate the name of your field?


CreatedDate is a standard field in Salesforce so it does not have the __c that custom field would have. If I were you I would use From__c.

I do not know how using an aggregate model affects this. Are you able to display the From__c date properly in a table?  If so then try the UI only field as a date. Then try it as text with the FormatDate function. Then try moving that to the export table.

Hope that helps.

Thanks Tony! I was able to work it out and I believe I did it in the way you describe. 

To answer your question, the From__c I am able to display in my table, however since it’s a DateTime (and it was showing as such) I created the UI (UI-1) so that I can trim the time portion by making it a ‘Date’. It was this UI-1 field that I tried to export using your formula; but it seems the issue was that I can’t reference the UI-1 field in the formula. (I guess the field can’t reference itself, it needs to look elsewhere). So… I created a second UI (UI-2) and referenced UI-1 in the formula. Now my export of the UI-2 field is showing properly.

thanks again!