Redirect url to a VF Page in Salesforce Lightning with My Domian enabled

I am testing out the lightning experience with Skuid and I am having a hard time getting my redirect URL actions go to a VF page instead of a direct Skuid page.

In SF classsic we would create an override for an object set a VF Page and then redirect to that VF Page because you can customize the tab name. This is not working in lightning.

Can anyone help me out on how the URL should look to redirect to a VF page from a Skuid API V1 (V2 would be great too) with My Domain enabled?

Hi Tami,

  • Have you discovered anything new about this issue since you posted it?
  • What version of Skuid are you using?
  • How do you revision the redirect working? Do you want to “leave” lightning and open the Visualforce page, or stay within Lightning?

I did some investigating and discovered:
  1. You cannot use relative URLs to get to Visualforce pages in Lightning, since the app remains in Lightning 
  2. I believe you can use the full URL to get the redirect URL to navigate to the Visualforce page
  3. If you want to use relative URLs, you should create a new Lightning page and put your Visualforce page inside. I believe setup should allow you to use relative URLs.
How to find the full URL for your Visualforce page:
  1. In Salesforce Setup, open the Visualforce page.
  2. Click on “Preview” to preview the page.
  3. Copy everything in the URL and use this for your redirect - should work in Lightning.

Let me know if this helps and if it works for you.

Hi Anna,

Thank you for all the info. I have been using the fill URL to redirect.

I have also found that when using a page override in lightening users that don’t have a Skuid license the standard SF page doesn’t load, the page just keeps reloading. 

Thanks for your reply, Tami. You said you’ve been using the full URL to redirect - has it been successful or are you still experiencing errors?

Re: using a page override in Lighting:

  • It makes sense that if your Lightning page has a Skuid page in it, it may cause problems for users who don’t have Skuid licenses.
  • Seems like the best way to accomplish this would be, in the Lightning page, to set the Component Visibility for your Skuid page component so it’s only visible for Users that have access to Skuid. See the attached screenshot: you can set up a component visibility filter in Lightning based on User properties, for example where the User > Profile > Name contains/equals/doesn’t equal (whatever profile you want).
    Is this helpful for you? Let me know if setting it up like this works or if you’re still experiencing issues.

Hi Anna,

Thanks for following up. Yes, using the full URL to redirect is working.

The other issue for non-Skuid users not getting to standard SF pages is still ongoing. I am not using a Skuid page inside a lightening page (at least I don’t think I am).

I am not sure where I would set the component visibility.

Here is how I have the Contact object set up:

  • Skuid page for the Contact Detail
  • In Skuid --> Page Assignments -->SalesForce Classic: --Object Type = Contact; Action Type = View; Applies To = Only Me
  • Created a Visual Force page with the following code:
  • Contact Object --> Buttons, Links and Actions View -- Generally I would set it to the VF page. --For testing I have it set to Standard Page ( Non Skuid Users still have issues)

Interesting… Just to be thorough I’d add another Salesforce Classic Page Assignment in Skuid for the Contact object where the Org Default is to redirect to standard layouts.

Hi Anna,

Thank you for getting back to me on this. I tried that as well and no luck.

Separate question Please reference the new conversation here: non-Skuid users not getting sent to standard Salesforce pages.