Pls help: Issue Connecting Data Source

Hi seems i’m having an issue setting up a basic postgress data source

Tried connecting to db with same credentials via other methods and no issue connecting. Error seems to point to an invalid IP which i assume is skuid? This Ip in error is always the same , no matter which host IP i use.

Unsuccessful
Skuid could not connect to the Data Source.
Please check all configuration values and make sure the Data Source can be accessed from Skuid’s web servers in your region.

{“message”:“Get "https://can56.salesforce.com/services/apexrest/skuid/api/v1/auth/token\”: dial tcp: lookup can56.salesforce.com on 10.43.0.10:53: no such host"}

Seems has to do with the domain prefix skuid is trying to use, it’s using can56 instead of Mydomain. If I try to manually navigate to url and change it to my domain i see something (if navigate to can56, i get a 404)
Still, no idea what i can do to fix this.

Hi Dave, how’s it going?

What version of Skuid are you using? Do review the prerequisite section of the SQL docs if you haven’t yet done so.

In the meantime, I’ll check with the team to see if I can get more clarity around this.

Hey Anna, I did check and that is not the issue, i’ve done this before more than once (been a while since last one). But seems it’s really a domain prefix issue, as almost any type of data source i try to setup gives me same error

I’m on 16.2.5 at the moment

In sandbox i just updated to latest release, and still same issue, so we can rule that out probably

1 Like

I don’t think this is the problem given the error message you are getting, however it would be helpful to have this info as part of our digging:

What version of PostgreSQL are you using and are you self hosting or leveraging RDS or something?

Do you happen to have access to an NLX (not Salesforce) site for Skuid? The error makes me think it’s something that is likely salesforce specific, which could help us narrow things down.

Hey Mike, thank you for assisting.

  1. I’ll get back to you regarding the info for postgress, but i highly doubt it’s related as any new data source i try to add i get this error.

  2. I do have the normal salesforce connection and one other external salesforce data source

Also regarding postgress: The version is 15, self hosting

Hi Dave, your org is on Hyperforce, correct? Some users on Hyperforce connecting to SQL data sources are experiencing similar errors. We’re investigating the issue and will let you know when it is resolved. In the meantime please let me know the criticality level and I’ll pass it along to our team.

Hey Anna,
Our org has been migrated to Hyperforce and it’s critical for us, as we use it on the daily almost to connect to our db and view certain data in sf.

1 Like

Thanks Dave, I’ll pass that information along to our team.

@Dave, another thing to try that’s helped others in this situation — make sure to whitelist your Salesforce org’s domain names on the external server if you haven’t already (not the IPs). This is what Salesforce recommends since with Hyperforce the IPs can change dynamically.

Sorry i was away, but will have my dev try, but as it seems to be same issue with all External Data Sources, I’m not sure this is where issue lies, but worth a try.
Pls keep me posted asap

Thx

1 Like

Hey Anna, wondering if any news/progress on this? Willing to do a screen share or grant login access if needed

let me know

Thx

Hi Dave, thanks for your willingness to help with troubleshooting. I’m passing your message along to the product team. We’re tracking the issue internally. If needed someone will reach out to you for more details.