Error when saving a page in builder: "insufficient access rights on object"

Hi all, I am teaching a member of our team how to use Skuid. For her first project, she’s creating a page that pulls data from a single opportunity record and its associated notes and attachments section. She has Modify All permission on the opportunity object and is able to create/edit/delete records in Salesforce. She also has a Skuid license, Skuid Page Builder and Viewer permission sets (I even tried temporarily giving her Skuid Admin permission set). She’s able to open a Skuid page in page builder and make modifications to it. However, when she goes to save the changes she made on the page-builder, she gets the following error message: “insufficient access rights on object id”. She is unable to save any changes she makes to the page on page builder. I have tried reading up on this error, but all I’m seeing are instances of people getting this error when they edit data in Salesforce, not instances of people receiving this error message when they’re actually using page builder. Does anyone have ideas for how I can resolve this issue for her? Thanks so much for your help! Regards, Aparna

Sorry, I realize it was extremely unwise of me to post this after 5pm on a Friday… Just wondering if anyone woudl be able to help with this issue. Thanks!

I have encountered a similar issue if the page has any scripting.   The user would need to have the Modify All (basically an ADMIN) to be able to save the page changes.  They can modify and save pages without scripts, but throw a script in there and the page is locked down.

In case anyone else bumps up against this, I had the same issue with a page that had no scripting. I fixed it by changing the sharing model (Org Wide Defaults) for Pages from Public Read Only to Public Read Write.

It is most definitely the modify / edit / view settings on the object that your model is referring to. Double check the models and the profile access for each type of user to ensure they have “modify all” rights. 

Alternatively to further trouble shoot, create a custom object and make a new model and see if you can replicate the problem.

I discovered it was the sharing setting when the same user could create and save the exact same page (XML) with no problems. Thus, the issue was with the Page object sharing, not the models involved.

Hello, i am having an issue with this and having a hard time following the solution.
Confirmed that my page does not have any scripting. So looks to be settings on the objects that i need to review. With regards to the answers posted above.

Do you set each Object that my models are using to Public Read Write?
Is this done on the Salesforce (Org Wide defaults?) side because i do not see an option on the Skuid design page.

new to skuid and trying to troubleshoot issues is compounded by not having the correct access rights.

Cross-posting this relevant info: