Can not navigate to detail record in Community site in API v2 (Spark 12.0.6)

I create a new API v2 page and add an Opportunity table to this page.

I expect it will be redirected to Opportunity detail page when I click on one Opportunity link on this table. The URL is changed in the browser, but the page is not redirected.

NOTE: ** This issue only occurs in API V2 and Lightning Community site.**

Please help to check.

Hi Kevin, thank you for the screenshots. I could reproduce the issue and will report it to our dev team. I’m looking into a workaround. Did you find a workaround already?
Regards,
Luzie

Hi Luzie,

This issue still occurs in Spark (12.1.6). Could you please help to resolve?

Thanks.

Hi Kevin, I’ll check it again. In the meantime, you could try this workaround:

  1. Add a row action to your table
  2. Use {{Name}} as label (given that this is the field that contains the opportunity name)
  3. add the action: Go to URL
  4. Use this as URL:

    Is this helpful for you?

Hi Luzie,

Thank you for your reply.

We applied this workaround, but the issue is it will be painful to apply for many skuid pages in community site.

Do you know when this issue is resolved in the next release of Skuid?

Thanks.

Hi Luzie,

Could you please help to resolve  this issue in next release if possible?

Thanks.

I believe that we have fixed this in one of our recent Spark patches.

Hi Zach,

After testing in Sandbox with Spark 12.2.9, I can still reproduce this issue.
We already need API V2 in the internal and community sites as well. Could you please help to resolve it soon if possible?

Thanks.

Can you grant login access to Skuid Support and provide us with steps to reproduce this?

Hi Zach,

It’s not difficult to reproduce. Only create a new V2 Skuid page and use it in Community.

Please note that this issue only appears in Lightning Community site.

Thanks.

Hi Kevin, I have been able to reproduce the issue, and we are investigating.

Hi Zach,

Does the issue have yet to be resolved?

Thanks.

Hi Zach,

Could you please help me with this issue?

Thanks.

Hi Kevin, from our conversation on the other topic (http://community.skuid.com/skuid/topics/open-a-detail-record-on-new-tab-in-community-site-doesnt-work) it sounds like you recently upgraded to 12.2.18.  

Are you still experiencing this issue after upgrade?

Hi Anna,

This issue is still occurring.

Hi Kevin, I did a bit more digging and found that this product defect has been fixed and is scheduled to be released in Spark Update 3. I’ll let you know when this release is available for testing.

Hi Anna,

I hope to get the Spark Update 3 soon.

Thank you so much for your help.

You’re welcome.