Anyway to set column headers to wrap-text and save some space?

I have some long field names, but the values in the fields are often only two or three digits. Right now, my tables become very wide - I’ve used the ‘fit to content’ option, but every column defaults in width to the length of the column header.

Version: 13.0.11

I think if you set the column width to something narrower than the header title, it will wrap

Hey @CRMF_Woj ,

Were you able to fix the issue?

I was not able to fix this yet. I was unable to find a setting in either the table display or the Design System that controls column width, or allows you to set one. I see Table and Row Height, and I can drag and drop column widths in the Design System - but I don’t see anything on Column Width, and none of my drag and drop changes pull through.

Hey @CRMF_Woj ,

A few things: the column header does dictate the column width, but if you are using V2 then you should already have “adaptive columns” enabled by default which the end-user can adjust the columns themselves to shrink the size.

Table — Skuid v14.0.6 Documentation

I have the same question. Yes, the user can adjust the column width but the column header just truncates, it doesn’t wrap, by default. Can this be changed?

Hey @TWyatt_Bluefin , something for you to try:

  1. In the table, select the column on the canvas that you want to set the width of
  2. In Field Properties, look for “Column width” and set it to your desired width (e.g. 80px)
  3. When there is a value in the “Column width” field, a new “Clip text” property appears. If you want the label to be clipped, leave it checked. If you want the label to wrap to as many lines as it takes to show the whole label, uncheck it.

I lmk that helps!

1 Like

Perfect, exactly what I was looking for. Thanks.

1 Like


Let me know if you need help with anything else! :smiley:

This also solved my issue! Thanks!

1 Like