XML Tree depth greater than 50

How do I resolve this?

This is not good.

Hi!  Check out this explanation of the XML tree depth from our engineer, JD.


Essentially you’re going to want to revert to your last known good version and pinpoint the portion of your XML that’s exceeding this Salesforce limit.  Once you’ve identified the issue, you will need to reorganize your page to avoid this conflict.

Good luck!

I suggest that you make use of a page include or two.

I have found that if you put components in components in components (like a Field editor in a wrapper in a responsive grid within a wrapper) you are maxed out at 10 of these layers. As Pat suggests, you can get around this by using page includes which count as separate pages so you can have more layers.

I created a page include but fields on the page were blank. This is the Query used: showheader=false&id={{Param.id}}

There is a page setting for showing or not showing header so you shouldn’t need that as a parameter in your query. Also, I don’t think URL parameters from the parent frame can pass into the the inline this way. You probably need a model on your parent page to receive the URL parameter then set the page include query to something like &id={{$MyModel.data.0.Id}}

The Query string used:


produced the same results, blank fields.

The fields do show up but no data in them.

I’m using the Drawer Action Type and wondering if this has anything to do with it?

My page include Condition is set as:

Your page include parameter has a lower case i and your condition parameter has an upper case i in “id”. Parameters are case sensitive.

I’ve tried various strings and still no luck :frowning:



Well, both I’s need to be capitalized. The second Id needs to be capitalized because the field name is capitalized. The first Id needs to be capitalized because the condition on your page include is capitalized. Do you have the “load model data on page load” set on the model in your page include?

Both I’s captilalized no data…

and the Load Model data on page load is selected…

sorry. Your query should be &Id={{$Model.Lead.data.0.Id}}

ok getting close, i think, cause at least I received an error shown below. Happy dance almost happened, but does this error mean I’m missing some field or? 

1. FirstName,LastName,Company,CreatedDate,LeadSource,Email,Status,Street,City,State,Country,Phone,MobilePhone,Title,IsConverted,LastModifiedById,LastModifiedBy.Name,LastModifiedDate,PostalCode,NumberOfEmployees,OwnerId,Owner.Name,CreatedById,CreatedBy.Name,Website,Industry,AnnualRevenue,
FROM Lead WHERE (Id = ’ 00Q3600000QGM4EEAX’) Error:invalid ID field: 00Q3600000QGM4EEAX

2. An error occurred while attempting to perform the following SOQL query: SELECT CampaignId,Campaign.Name,Status,HasResponded,CreatedDate,Id 
FROM CampaignMember WHERE (LeadId = ’ 00Q3600000QGM4EEAX’) LIMIT 101 Error:invalid ID field: 00Q3600000QGM4EEAX

Hey Raymond, 

I was able to clear those errors, but my fields are still blank :frowning:


simple thing, but make sure that you don’t have any models on your parent page and included page that have the same model name. more than one model with the same name will confuse the skuid.

Agree with Matt. You should also try putting {{$Model.Lead.data.0.Id}} into a rich text field on your parent page to see what Id number populates. Then see if that Id number corresponds to the Id of the record you are trying to pull up in your page include

All - I just skimmed this thread (admit to not reading every piece of it) but if my skimming was accurate, you’re attempting to use a page include from inside of a drawer.  If that is the case and unless something has changed with Skuid recently, this is not supported.  At a high level, the reason for this is the way page includes are “brought in” to the containing page and the fact that drawers require multiple instances of the same page include.  See https://community.skuid.com/t/fields-with-rendering-conditions-not-displayed-in-a-drawer-….

doh! Thanks for the reality check, Barry.

Aaah, well, hmmm, what’s the best way to redirect it? Using the Redirect to URL Action Type?