Why is REST API Query Method Merge Parameter Not Working after Boston Update?

Hi all,

I am having an issue with a REST API query method merge parameter not working after upgrading to Boston.

When I attempt to view the fields, I get the following error:

I get this same error if I pass nothing instead of the merge parameter. It works if I hard code the Data Source URL to the sample value. This leads me to believe the merge parameter is no longer being merged into the url.

I tried using triple braces, but that did not work.

Any ideas on how to resolve?

Hey @Matt_Leedham,

If you’re using an Apex proxy, the response from your Dynamics endpoint is still subject to Salesforce heap size limits, hence this error. To resolve this you must disable the Apex proxy: In the Skuid UI, navigate to Configure > Data Sources. Click Edit beside the Dynamics data source encountering this error. Uncheck Use Apex Proxy. Note Doing this may not conform to your security priorities. Concerns about heap size limits should be balanced with your security policies and security best practices.