Validation firing on fields not shown due to conditional rendering

I’m encountering an issue where I’m getting a validation message on a required field that is preventing me from saving/creating a record even though the fields are not displaying in the page due to conditional rendering.

I was under the impression that fields hidden by conditional rendering were not validated?

(Just to confirm, I am only using the Skuid ‘required’ functionality, the fields in the screenshot below have no ‘standard’ salesforce validation enforcement)

Hopefully someone can help.

Thanks in advance


From your picture I can faintly see that this form is in a popup.  That means that other fields are “visible” behind.  If the fields that are triggering the validation errors are shown ANYWERE on your page - the validation rules will fire.  Even if they are on another wizard step. 

Hi Rob,

These fields are not displayed anywhere on the form behind & no wizard is being used.



Any resolution on this one? It has recently reared its ugly head for us. 

There is a multi-picklist that controls rendering on other fields. If you accidentally choose one value on the picklist, and then change it back, it will trigger a validation error. Whether you put any data in the field or not.

Any ideas?


@Sarah, Thanks for that. I just went back and tested my page and found this to be the cause of my problem too.

Look forward to seeing if Rob has a resolution.

Guys,  I can’t make this fail.  

Maybe I misunderstand what you have set up. 

- Field 1 is a mutlipiclist field. 
- Field 2 is set as required in the UI  (not required in the back end setup)
- Field 2 is only rendered when Field 1 includes value “foo” 
- I set Field 1 to include “foo” and enter data in Field 2 - but then remove it - so that the requiredness trigger would fire.
- Then I set Field 1 not to include “foo” - Field 2 dissapears. I push save and the required field is ignored.

What have I got wrong?  

And finally:  What version of Skuid are you running?   Have you installed the latest verion from Get the Latest Skuid Releases & Everything That Came Before


We are on version 6.8.7.

I am doing exactly what you describe. See the recording below:

Are you willing to go to our latest patch release?  Available at Get the Latest Skuid Releases & Everything That Came Before.   And one more time… are you sure this field is only required in the UI.  Can you make it not required in the skuid page?  If it is required at the database level,  you will still get this error. 

We are willing and might be able today!

I just double-checked, the fields are only required in the UI, not at the database level. I will report back after getting the newest patch up.

Rob, we updated to the latest patch and are still getting the error…

Would you mind giving us login rights to your org so we can take a look at what is going on?  
Here is how:

Use this tutorial to give us login rights:….

Then send an email to  with the following information: 
1. Your Org ID
2. The name of the skuid page where this is happening. 
3. The specific steps that you used to get this issue…
We’ll see what’s going on…

Sarah.  Here is the issue. 

Your conditional rendering is set on the Section,  rather than on individual fields.  After they are first rendered, the inidividual fields do not know they are removed,  and so they are evaluating themselves for UI only requiredness.   I know its redundant, but if you set up the conditional rendering on the field - as well as on the section - the field will know not to keep its changes when it has been hidden.

I have changed the form in your org,  but have not tested it.  Confirming that saves don’t work is one thing,  confirming that saves do work is somthing I’m less comfortable doing. 

Please let me know if this solves your problem.  

See, I was trying NOT to do that! :slight_smile:

Problem is solved. Thanks, Rob!

Glad we could figure it out…