Using Skuid Export Function in Community - Page not Found


We are using a custom snippet on an export button on a community page to allow users to export their search results. This snippet uses the skuid export function to provide the output. Currently, we are seeing that while logged into the community, the page attempts to redirect to 

We gave the community profiles access to this visualforce page, but it is still throwing the redirect error. 

This snippet works in a non-community environment. No issues with the export firing correctly and presenting us with a shiny new spreadsheet with informative goodness.

This was solved by following the instructions to recreate the ExportData visualforce page.


Hi Rob,

We are also facing that same error in site.

Can you please let me know how we can fix that error?


Hi Rob,

I got it answer here:

Before you can reliably use the skuid:page Visualforce (VF) component approach, there is a post-install configuration step you will need to take to guarantee that your Skuid Pages will behave exactly the same as they would if you were taking the Redirect approach:

You must find the following 3 VF Pages that come in the Skuid app / managed package, and create a local clone of each of them with the exact same name:

  1. ExportData
  2. UploadImage
  3. Include