User Id is populated instead of user name in the look up field

Hi I have a table which shows the list of Users who have used certain Asset at some of time. This table have drawer and Global action associated with it. The Drawer shows the more details about the user and global action is sued to add a new user to the asset. Now when i click the New assignment button, the following screen is displayed. The assigned By field is showing the User id here. But i want the user name. I tried different conditions like 1. Assigned_By__c is = to the Running user ID. 2. Assigned_By__c is = to the Running user Full Name. 3. Assigned_By__r.Name = to the Running user Full Name. The model behind the new assignment button is different from the model behind the drawer. But the salesforce object behind every model label is the same. none of the above conditions are working properly. Can anyone help me out with this issue? Thanks.

Hi Avinash - I fought with this same problem recently.  See Rob Hatch’s response in the thread linked below.  It explains why this is happening and how to fix it.

I added that action on the Table Action properties which now looks like this But Now i am seeing two rows being created when i click to open the pop up. Where am i going wrong?

See if this helps, be sure that the model for the new record is empty before starting the new one.
Here’s what my config looks like:

Awesome!! It worked. Thank you so much.

Glad to hear it!