Unable to use "Build in Lightning" in latest release

I’m trying to create a new page and edit in Lightning mode. When switching from the Visualforce editor, once the Lightning builder loads, I get a message at the top saying “There were 2 problems with this Skuid page” Upon clicking that message I get the following items highlighted:

1. An error occurred while attempting to load the “skuidvis” component pack. Error: Argument cannot be null.
2. An error occurred while attempting to load the “skuidcore” component pack. Error: Argument cannot be null.

I’ve made sure I’ve started with a new page, I’ve tried installing the package a second time, but to no avail. I’m going to try a uninstall and re-install, I’ll let you know how that goes.

FWIW, I installed this in a pre-release org on gs0.

Just to confirm - uninstall and reinstall hasn’t solved the issue…

Does your GS0 org have My Domain enabled?

Speaking of which, Zach, do you have any idea why Salesforce is making Lightning Components dependent on switching to My Domain??? I understand that there is some sort of security benefit, but why only Lightning???  

My guess is it has something to do with trying to protect the “Lightning Experience Setup menu” — one of the Salesforce’s Security team’s biggest concerns is protecting the Setup menu from any sort of security threats, so if Lightning Apps / Components could run in the same domain as the Lightning Experience Setup menu, there would be opportunities for JavaScript to mess with the setup menu since they’d be running in the same domain (e.g. na12.lightning.force.com). 

Yes, My Domain is set up.

Are there any Lightning settings I need to set up beforehand? Lightning development is enabled but I’ve not activated Lightning Experience

Also saw there was an update - 7.20. Upgraded, but still not working.

A few points to add:

- A colleague with a Summer 15 dev org has 7.7 installed - and Build in Lightning works. This org does not have My Domain
- I uninstalled 7.20 in my org, and installed 7.7, but started getting Lightning gaks when trying to switch to Lightning mode
- Next version available was 7.19 - this has the same issue as the one I originally reported.

I’m going to try and sign up for another pre-release org and not set up My Domain in the meantime.

Zach, looking again at the thread, I may not have put two and two together… Is this a known issue when My Domain is enabled?

As of the Winter 16 release, My Domain has to be enabled for you to be able to Build or Preview Skuid Pages in Lightning. And you should install the latest Banzai Update (7.20), you will get other issues with Lightning when using the earlier Banzai versions.

I have a GS0 org, with My Domain enabled, that is running 7.20, and Build Page in Lightning works fine.

One thing that you do have to do (that is not obvious and which is a consequence of Lightning’s highly-aggressive caching), is that you need to do a Hard Reload of your browser when attempting to Edit a page in Lightning. To do this from Google Chrome, open the Console, then hold down the refresh button in the top left until you get a menu that lets you choose “Empty Cache and Hard Reload”. Click this. This should get the Page Composer to run in Lightning if you’re seeing a blank / white page.

Still no dice I’m afraid :frowning:

I’m not seeing a white/blank page, but I’m getting the error messages in the alert in the top of the page, about being unable to load skuidvis and skuidcore. I don’t see any failed network requests, so I think things are being loaded across the network, and the error looks like it’s a runtime error.

I’ve had a dig around. In the Lightning builder, there doesn’t seem to be any reference to “skuidvis” as a search token in the source files; but then skuidcore appears in both, so I think that’s a red herring.

I’ll try another org on Monday.

Could you grant login access so we could take a look?

Done - my username starts with gary.breavington-wrbh

Appreciate you taking a look - and apologies in advance if I’ve done something braindead…