Unable to upgrade Skuid in a Salesforce Sandbox to Rockaway - Iteration 15 (8.15.17)

I tried twice recently to upgrade Skuid on our Salesforce Sandboxes from Rockaway - Iteration 10 (8.15.8) to Rockaway - Iteration 15 (8.15.17) without success.

Here are the steps I performed:

-opened the Skuid Releases page
https://www.skuid.com/releases/salesforce/ [^]
-opened Changelogs and Past Releases
-opened Rockaway - Iteration 15 
-clicked Sandbox 
Message: An earlier version is installed. It can be upgraded while preserving the existing data.
Installed: Rockaway - Iteration 10 (8.15.8)New Version: Rockaway - Iteration 15 (8.15.17)
-clicked Install for All Users
-clicked Upgrade
Message: This app is taking a long time to upgrade.
You will receive an email after the upgrade has completed.
-clicked Done
-didn’t receive email confirming upgrade
-reviewed the Package Details: Skuid (Managed) page & the Version Number  is still 8.15.8

Any thoughts on how to resolve this issue?

Your steps look accurate. How long have you waited for the upgrade?

The last time I tried to upgrade was 2/22/18.

What happens if you try again? Also, is there any particular reason why you’re going to 8.15.8 rather than Brooklyn?

One of our developers who created an app using Rockaway 8.15.8 wanted a Sandbox installed with Rockaway - Iteration 15 (8.15.17) for testing purposes.

I’ll try upgrading again.

Sounds good. Let me know how it goes.