ui-only formula fields cannot compare to strings???

Here’s a simple formula:


In runtime, I get the error:
“Invalid syntax for field formula: IF({{Status__c}}==‘Scheduled’,true,false). ReferenceError: Scheduled is not defined”

Here is the syntax I have used to good effect: 

IF({{StageName}}==“Needs Analysis”,“Hop To It”,“Chill”)

I think double quotes are your friend… 

No luck:

Invalid syntax for field formula: IF({{Father_of_the_Baby_Intention__c}}==“Abort”,true,false). ReferenceError: Abort is not defined


This still an issue for you?

Briefly had the same issue until I found this post and saw the double equals “==”.

Your formula is using single quotes and I get the same error when using single quotes. Have you switched to double quotes?

I believe this was fixed with 7.19


Anyway to do the same for large text type fields to see if Null?

IF({{field__c}}== “”,0,1)

When I tried i get the following error: SyntaxError: Unexpected token ILLEGAL


We’re trying to generate a UI-only field (checkbox) to indicate if a large text field has contents as well - any tips?