Trying to add a filter to a search but nothing is showing to add that filter

Looks like a bug. I’ve tried refreshing, X’ing it out and trying again. Updated from 7.19 to 7.20 and still not getting the info I need to set up the filter (yellow box)

Yeah, I feel like I had this problem the other day too, also with a Lookup Filter. 

We’ve reproduced the error and have a bug up and running.  It does look like there is a workaround.  If you add a new reference field,  the filter properties work.  It is only when you open a page with an existing reference field that the filter properties are blank.  So…   Better get it right the first time, cuz there’s no going back! 

What do you mean by “add a new reference field”?  I’d rather not have to rebuild this whole wizard…

Ugh. That would be painful.  What I mean is that if you just drag the “Request Type” field into your component again - you should be able to set the filter properties for it.  Then delete the old version.  One field, not the whole wizard. 

Random, but effective fix.  That worked.  I had the same field on there twice (different field editors display based on rendering conditions) and replacing the field once allowed me to set the filters on the other version of the same field.

Thanks

Any chance this will be fixed with update 5?

I updated to version 7.27 and the filter functionality on a lookup field is working when it didn’t before the update.

This issue has been resolved in Banzai Update 6, available from the Skuid Releases page.