Troubleshooting: New picklist values aren't displayed on Skuid page

PROBLEM: New picklist values aren’t displayed on Skuid page.

RESOLUTION: New picklist values need to be added to the correct Record Type in Salesforce Setup.

Problem Details

This is about a picklist field in a Field Editor component on a Skuid V1 page. The Model name is OrderSales, the custom picklist field Chocolate contains three values: Milk, Dark, White. A new value, Almond, was added to the picklist field in Salesforce setup (left screenshot). When previewing the Skuid page, the newly added value wasn’t displayed (right screenshot).

Resolution Process

I checked the Skuid version quickly in the browser console. If this was an older Skuid version, it could contain a product defect that might have been fixed in a later release. It was the latest release, though.

I tried to make sure that the browser previews the latest changes. I opened the Chrome console, right-clicked the refresh button, and selected “Empty cache and hard reload,” but the new value didn’t wasn’t displayed. I also cleared the site data under “Application” and reload the page as described above, but no new picklist value appeared.

To eliminate the possibility of stale cache, I previewed the Skuid page with a different Chrome profile, as well as in a separate browser, but the new value wasn’t in the picklist dropdown.

I double-checked that the Record Type OrderSales included the new value. It did, so this shouldn’t be an issue.

Since there were a lot of models, components, action sequences, etc., I created a new Skuid page from scratch to check if this issue is page-specific. On the new Skuid page, I added a single model, OrderSales, that contained the picklist field. I then added a Field Editor component that only contained the picklist field, and previewed the page. Unfortunately, the new value did not display, so I could rule out page-specific reasons.

In the Skuid Model, I went to the list of Fields and clicked “Refresh Fields” (two arrows icon), then refreshed the Skuid page preview, but no luck.

In Skuid Configure → Data Sources, I checked if Metadata caching was enabled for the Salesforce data source. It wasn’t, but if it was, I would have tried to Refresh the metadata cache.

In order to check if this might be a product defect, I created the same page in a separate Salesforce org. Furthermore, I created a new Salesforce object, new picklist field, and new Record Type. The new value appeared in the preview, so I could rule out a general product defect, and instead focus on the specific org in which the issue occurred.

In the browser console, I checked the first Model row details, and it showed that the Record Type in use was FoodSales (and not OrderSales). So I checked this Record Type in Salesforce Setup and the new value, Almond, was NOT in the list of available values.


The new value was not visible on the Skuid page preview, because it wasn’t added to the list of available values of the correct Record Type. In order to find out the Record Type in use, I entered the following line in the browser console and hit enter:


It showed the Record Type FoodSales.

But the new value hadn’t been to that Record Types list of values. After I added it, and refreshed the Skuid page preview, it was displayed in the picklist dropdown as expected.


If data, or metadata, isn’t displayed as expected, always check Record Types. Use the console to check which Record Type is in use on the Skuid page. While building the Skuid page, we recommend adding the Record Type field to the top of the page to double-check if it’s the one you expect. Different users might see different data, so test with different users.

Get help with an issue

Ask in the Skuid user community in the questions category.

If you have paid support, ask your question on our support portal

If you’re interested in support, contact your Account Executive.