THIS_YEAR ,THIS_MONTH,TODAY and THIS_QUARTER NOT WORKING on GRID PAGE

I have one field called registration date.I have added manual select option filter.
There i have used THIS_YEAR,THIS_MONTH and other date filters.
but it is not working.
I have provided xml.Please check and let me know where I am doing mistake.

Employable Job Seeker &

You have to check Reg Date Filter.

Hi Rohit, I was able to get THIS_YEAR, THIS_MONTH etc. to work in a custom date field filter in this way:

  1. Create just one condition on the date field without a value and set it filterable default off.
  2. Then create a manual select option on that date field condition.
  3. Manually add options to "affect the default condition" and enter TODAY, LAST_YEAR etc. for the value. This should save you in the future from having to make a condition for each value.
Is this what you tried to do? It looks like your XML got cut off before the filters section. Can you send just that section so I can better see what's going on?

This is not working for me.
Find out filter code.
Below is condition

below code of filter






































This filters are working fine in old release but after 8.6.20 I found this issue.

It looks like your filter is set to a different condition. Try substituting this for the first couple lines of the filter and let me know if it works:


<filter type="select" filteroffoptionlabel="Reg Date" createfilteroffoption="true" affectcookies="false" autocompthreshold="25" conditionsource="manual" labelmode="no" condition="<b>THIS_YEAR</b>">

This also not work for me.