There was an error attempting to load the requested page

I am received the above error when attempting to load a page from a newly created tab. The VF page that controls the page include is included for the profiles experiencing the issue. The link to the page works fine for everyone, but the tab does not.

It may be caused from two tables on the page being conditional rendered by profile. When I remove the conditions, both tables load fine. Very odd.

Error when logged in as a user:

When logged in as myself:

Joe,

Can you check that the profiles have the Include Visualforce Page Access?

Thanks!
Amy

Yes the VF pages are included for all of the profiles in question. The VF page is loading correctly, it is struggling with the page includes. 

Joe,

The Include Visualforce Page is a standard Visualforce page that controls if the profile can see any included pages, so if those profiles don’t have it they won’t be able to see any included pages (even if they have access to the pages that are included). It’s more of a security setting than an actual page. Would you mind checking the profiles to make sure the Include page is listed on their Enabled Visualforce Pages?

Thanks!
Amy

Ahh sorry, I sped read your post. That did the trick! Thank you!

Hi Amy, we can’t find the Include page anywhere…
It’s a standard page of salesforce or is it a Skuid standard page?

Because if I go in the visualforce section , I can see only one page that is called Include that has been created by Skuid


Then I go into the profile options for the visualforce pages and I can’t find your page anywhere, nor I find any page with an Include name (if it’s a standard salesforce page, maybe its name gets translated?)

Because we have the problem that with the profile that we are trying to use, if we go directly to the link the user can see the content, while if we try to access from another page, it gives us the error “There was an error attempting to load the requested page”

Thanks a lot
Giovanni

Giovanni,
I’m pretty sure that it’s a standard page of Salesforce, so it might have gotten translated. Let us know if you look again and can’t find it.

Thanks!

Hi Amy,
I am a colleague of Giovanni.
the problem seems to be that we have both community licenses and “complete” salesforce licenses.
and the people with the community license can’t see anything, while the internal user can see it, both internal and community user have same profile.
Any idea?
Thankyou

Do the community users see any type of error (for instance about insufficient privileges), or do they just see blank pages?

Hi Amy,
only the “There was an error attempting to load the requested page” in the embedded template

Did anyone find a resolution to this issue?  I have the same scenario where a community user is unable to see the page include.  I was unable to find a visual force page called Include.  Instead, I’ve enabled access to the skuid.include page we no luck.

Andrea and Adam,

Sorry for the late reply! It looks like you may need to clone the standard Upload and Include Visualforce page as per this tutorial (under the Prerequisites section) and then grant users access to those cloned pages. This topic is also discussed here and here on the community.

That worked for me. Thanks for the links.

I had to do the above as well as granting VF Page access to the site user as described here:

http://community.skuid.com/skuid/topics/there-was-an-error-attempting-to-load-the-requested-page

This solution has not worked for me.  I went through the tutorial to clone and enable as well but that still did getting the same error as Rajendra Rathore.  Is there any updated fix I can try?