Theme composer loading issue with Brooklyn Iteration 4

I am trying to open an existing theme called “Kiosk” using theme composer in a sandbox but unable to do so. It never loads. We are using Brooklyn Iteration 4 (Version Number 9.3.4). Attaching some screenshots. Please help!

Hi Rups

Check your static resources.  It may be that the file did not move over from production.

If not export the theme from an org where it is working and import it into the sandbox.

ciao

Rups,

Additionally, if there is an update button that shows on your theme page, click it to update your themes (if it’s not there it just means your themes don’t need to update).

Thanks!
Amy

Thanks a lot.  I see an “Update Out of Date Theme” button but was just wondering if after updating we would lose the work that we have done on our custom theme so far which we are also using in Production? I appreciate your prompt response, Amy. :slight_smile:

Thank you, Gregg. I appreciate it!

Rupali,

You won’t lose your work on any custom themes you’ve worked on

Awesome. That’s great news. Skuid rocks! Happy to use it. :slight_smile: Thanks once again. :slight_smile:

Hello, I have this issue to. I hit update themes, but it’s still not opening. On the static resources page, it shows as being last updated 9th Feb (today) but still not opening. any ideas?

Did the update themes action finish or is it endlessly spinning? You might also try opening the theme in an incognito window of your browser to see if something in your browser is interfering (I saw some odd behavior with this the other day - I couldn’t open the theme in my normal browser window but I could in an incognito window, so maybe some interference with my browser cache?)

Thanks!

I’m experiencing this issue as well on Ver 9.5.4 (posted about it here before finding this thread: http://community.skuid.com/skuid/topics/theme-composer-page-doesnt-load-ver-9-5-4)

The Incognito Mode trick worked once! Upon creating a new theme, the page loaded properly. But as soon as I refreshed the page, the new theme began hanging again.

This reply was created from a merged topic originally titled Theme Composer page doesn’t load - Ver 9.5.4. Walkthrough of issue in vid below.

Roman,

I originally suggested opening the theme in incognito as a way to troubleshoot. For instance, if the theme loaded fine in incognito then maybe you could clear your normal browser’s cache and your problem would be fixed. However, it seems like that’s not of any help for you, so I’ll investigate some more and see what I can find out.

Thanks!

Thanks Amy. Just tried Firefox and I’m getting similar error messages in Firefox’s Console as well.

I’ve included screenshots below.

Firefox - (Developer Edition 54.0a2)
.

Chrome - (ver. 57.0.2987.133)

Again, we’re running the most recent version of Skuid 9.5.4 - so I’m really surprised more people aren’t reporting the same issue. No one in our Org can edit a theme though, so the issue isn’t isolated to just my terminal.

Roman,

This is quite the sticky problem. Are any of your themes cloned themes? If so are they experiencing more/less issues than the others? Did Mark’s reply on this post help, or are you guys still having trouble editing themes?

Amy, so Mark’s work around did in fact help us with editing an ‘original’ custom theme - which seemingly is editable from the theme composer and working as of right now!

However, the other custom themes we have, which are clones of this original are still stuck with the console errors that I screencapped above. So I believe you’re right in your suspicion that cloned themes may be at the root of this bug… 

I am having this problem too (9.5.5) the page does not finish loading in Chrome, but the page does finish loading in Firefox

Roman,

I’m glad to hear that Mark’s workaround helped with custom themes! Unfortunately, it looks like there’s an issue with cloned themes. I’m currently talking to the team to see if there’s any workaround.


William,

In Chrome, can you try opening the Chrome developer console (CMD-OPT-j) and then long-clicking the refresh button at the top left of your window? Then, select Empty Cache and Hard Reload from the little dropdown that appears. I think that will help with your custom themes (that aren’t clones).

Thank you for your patience! Skuid has fixed the issue with loading cloned pages (issue SKUID-3121) in the new Brooklyn -Update 1, Iteration 6 (9.5.6) release which is now available on the Skuid Releases page.

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.
 
Thanks again for alerting us of these issues! 

Hate to be the bearer of bad news, but we are still experiencing many problems - to the point where creating a new custom theme simply isn’t possible at the moment. Let alone having the ability to edit/update a pre-existing one. :frowning:

Take a look at the video below:


Several clients, including our own Org, are eager to implement theme updates. So really hoping we can resolve these issues together somehow. Thanks.

Worth pointing out, that the console errors I took screenshots of in an earlier (in chrome and firefox) did not show up in the new video. So seemingly, those specific problems have been addressed.

But then again, I couldn’t get a single theme to load. So there’s that too… haha! :stuck_out_tongue: