Theme composer is not loading up

I’m trying to create a custom theme by picking :Mobile Classic" as base theme, but the theme composer page is not loading up (see snapshot).
I’m using Mac, Skuid v10.0, Google Chrome browser.

I’ve seen this before as well.  Mainly using Chrome on Windows 10.  After waiting some time and trying again it works.  I’m not entirely sure how to replicate effectively.

We’re aware of this problem internally and are working to speed it up. If you clear your cache, it’ll load faster.

Any progress on this one? Workarounds?

I was able to create a new theme, and made some significant customizations. But now I can’t edit the theme. Just stuck on Loading… forever.

Also, getting a warning in the console: skuid__EditTheme?id=a0D4100000Djt3EEAR:1 The certificate used to load uses an SSL certificate that will be distrusted in an upcoming release of Chrome. Once distrusted, users will be prevented from loading this resource. See for more information.

It’s faster on newer versions of skuid. It’s still not as fast as we would like it though.

My problem is not that the theme builder is slow to load. It’s that is DOESN’T load. Unless by “not as fast as we would like it” you mean 4+ hours?

What version of Skuid are you running?


I’m a little confused as to your posts. You were able to create a new theme but your theme builder won’t load?
What was the base of the theme you built that won’t open any more? We had upgrades in 10.0 that fixed certain themes that were unaccessible after being made


Sorry, I was writing out of frustration, and not being very clear.

Here’s what’s been happening:

  • When I attempt to create a new theme, the theme builder doesn’t load. However, I found that if I let it try to load for a minute, and then refresh the page, it will sometimes load. I was able to get that to work for two new themes.
  • When I try to open either of my themes (or any theme, for that matter) in the theme builder, it doesn’t load. However, if I try the same trick (wait 15 seconds, then reload), it will finally load mayber 10% of the time.
  • Occasionally after a reload attempt, if the page still isn’t loading, right clicking and ‘inspecting’ the page will magically cause the builder to load. Works about 25% of the time.

I’ve had exactly the same thing for a few months now, particularly in Chrome. I’ve had better success with Firefox, but a reliable workaround has been to login via a incognito/private window.

Usually, if incognito mode solves the problem, then the problem is found in caching. Clearing your browser’s cache should help tremendously.

That’s really strange behavior. I don’t know how much I can be of service other than to say you should consider upgrading your version of skuid.

I’ll try the incognito option.

Based on your earlier recommendation, I cleared my cache before every attempt at the bulletted steps above.

I still encounter the same issue for Skuid version 11.0.3. I tried using incognito in chrome and mozilla firefox and cleared my cache, but not able to use the theme builder

I’ve been trying periodically all day to edit my theme, with the same results. Endlessly loading. Check this out …

That’s Opera at top left, Firefox bottom left, Chrome Incognito top right, and my normal Chrome bottom right. Both Opera and Firefox have empty cache. They’ve been running for about ten minutes.

I created a new theme to test, same results.

I tried exporting my theme. My plan was to import it to a new theme. But all four browsers instances fail to do the export. Results are:

  • Chrome/Chrome incognito: “Requests to the server have been blocked by an extension.”
  • Opera: “O is blocked. Requests to the server have been blocked by an extension. Try disabling your extensions.”
  • Firefox: no error, but no export either.
    No luck disabling extensions/add-ons etc. and trying again, same results.


Skuid 11.0.3

I don’t think browser versions matter in this situation, but they are:

Opera 52.0
Firefox 58.0.2
Chrome 65.0.3325.181

Updated a sandbox to Millau (11.1.8), cleared cache … Theme Composer still not loading. Sad face.



When the theme tries to load, console returns these errors:

Uncaught DOMException: Blocked a frame with origin “” from accessing a cross-origin frame.

… which appears to involve browser same-origin policy settings:…

Also, a consultant who works on our instance from another location found that he did not get these errors, and was able to load the theme composer.

We ruled out LAN. His browser or OS environment may be different. Which is nice and maybe we hack away at our browser or OS settings to resemble the external consultant’s. Without putting in time to learn more about the same-origin policy, that seems a bit reckless. 

The nature of the errors reminded our sysadmin that we recently enabled two Salesforce Security Session Settings for Clickjack Protection:

  • TRUE Enable clickjack protection for customer Visualforce pages with standard headers
  • TRUE Enable clickjack protection for customer Visualforce pages with headers disabled 
After fiddling with these, we found that the following combination resolves the theme composer error:
  • TRUE Enable clickjack protection for customer Visualforce pages with standard headers
  • FALSE Enable clickjack protection for customer Visualforce pages with headers disabled 
Now I can modify my theme! Which is great.

If anyone from Skuid can provide info on the following, I’d appreciate the illumination.
  • What is the conflict between theme composer and the Salesforce Session Setting  Enable clickjack protection for customer Visualforce pages with headers disabled
  • Can this conflict be resolved in a Skuid update?
  • Is the browser same-origin policy relevant to this problem?

Thrilled to hear it’s resolved. Thrilled even more to see your response here!

Hi Tim, I see that you asked for more feedback at the end of your post, though I know it’s been quite a while. The conflict between Theme Composer and Salesforce Session Setting you mention is just that if you enable clickjack protection for Visualforce Pages with disabled headers will encounter the cross-origin error. The Theme composer is a Visualforce page (in the Skuid namespace), and I believe its header is always disabled, so it can be affected by settings like these.