The entity is locked for edting

I have a skuid page as an override for a custom object tab. There are two models on the page: one for the main custom object, and one for a detail custom object that is displayed in a drawer. The main save button is configured to save both models.

When I try to use the “Mass update” for the top level object, or simply modify two top level rows at once, and then try to save, I get an error:

“the entity is locked for editing”

3 out of 4 rows failed to update in the mass update test. All rows failed when making manual edits on multiple rows at once.

In the scenarios above, the drawers with the detail object are not involved.

I can save changes for all of the detail rows for one top level record without an error, but if I try to update detail rows on more than one top level record, I get the same error.

Thanks for reading!

Hey, Jared,
So far, I haven’t been able to reproduce the issue, though I may be missing something. You may have already checked this, but just to clarify, have you tried going through each top-level row and trying to edit/save individually? Have you gone through each top-level row and attempted to edit child records individually? I’m just wondering if you’re getting a permissions error related to one of the records in the list of records you’re trying to save.

Thanks for the response, Emily.  It’s not a permissions issue as this occurs with an account with access to view/modify all.  I did find this, however, regarding the limitations of save/cancel buttons on the page title component:

I added a global action to the top level table to save all models.  But after further testing, the save button in the page title seems to be working now.  Strange, but at least it’s working.  Just hope it stays that way :slight_smile:

Hm, weird. It seems strange to me, though, that you were only able to edit the second record in the table, not the first record, as in the post you referenced. Oh well, I’m glad it’s working now. Let us know if you run into any more issues.