Testing: Theme Composer in Banzai - page doesn't load

I am testing out Banzai - Release Candidate 4 Release 7.5. I created a new Theme and when I try and go to edit the theme the page tries to load but never finishes.

Back on the Themes list page, check to make sure your Theme does not contain anything in the “Resource Namespace” field, unless the org you are in is a Managed Package development org. This field is a common source of confusion, and we’re working to add better error messaging to the Theme Composer in the next version of Banzai.

Thanks Zach clearing the namespace field did the trick. FYI: This documentation directs you to fill in the name space.

Hey Tami, sorry that you ran into this problem! The documentation did address this issue, but not very clearly and the pictures were misleading. I’ve updated the documentation so it’s clearer. Thanks for helping to make Skuid better!

Thanks Anna! Happy to help.

I had the same problem (and made the same mistake) … but this doesn’t seem to have fixed the issue. Still shows a greyed screen with “Loading Theme Composer …”

Two things would help us debug this: can you post a screenshot of your Theme record in the Themes table, and can you open the JavaScript Console in your browser (Cmd+Option+J in Chrome on Mac) and see if there are any JavaScript errors?

Here’s the screenshot showing my Theme in the list … I did also get a javascript error: – Uncaught TypeError: Cannot read property ‘baseTheme’ of undefined Here’s a screenshot of as much of that error as I can capture:

Can you check which version of Banzai are you running (from Setup > Installed Packages)?

Also, which Base Theme did you clone from?

Version 7.7 This was based on CleanGreen. I also tried to create one from Ice Age and it got locked up trying to create the initial theme page.

Hi all, I’ve got a similar problem with a custom theme. The Resource Namespace is blank, but when I open in Theme Builder it gets stuck on the loading screen.

Also when I try to open any pages with this theme, I either get a blank blue screen underneath all the Salesforce Tabs, or some weird calendar component in that same blue section. When I change the theme of those pages back to Default, the page loads.

I’m in Sandbox on version 7.20.

Any updates?

When you look at your Theme in the lists page is there an “update” icon beside it?

Click to edit your Custom Theme, and then Save it, and then try again.

Zach, he actually can’t open his Custom Theme to even save it.

Usually the most common reason for a theme not loading would be improper namespacing. As Zach said above, keep the namespace blank as long as you are not in a managed package. You’ve left the namespace blank so, just to confirm, you are not working in a managed package, correct? Otherwise you need to use the proper namespace prefix.

If that still isn’t a problem, I might need you to answer a couple more questions so we can diagnose what’s going on. Is this a theme that you’ve already done some work on, or is it a new theme? Have you been able to get any custom themes working in your org? Either way, I think screenshots what the Skuid page looks like with the theme applied, what it looks like with the default theme, and any errors appearing in the JavaScript console would be helpful.

I ran into a similar problem and ended up having to rebuild the theme. It seemed that somehow the theme became corrupt. I don’t know if it has something to do with the initial Banzai release but I have not had a problem with the custom themes since applying the updates.

Hi all,

Yep can’t open the theme. And its not for a managed package.This theme was built and working prior to banzai. I haven’t tried any new custom themes or other themes. And yes have tried the Update function. Some screenshots below:

The custom theme Tyrrells

When I try to open in Theme Builder, it stalls on this page

A sample page using this theme

When I open this page, this is what loads, and the javascript console shown. No related errors that I can see.

Lapman, can you grant login access to Skuid Support so that we can investigate the cause of this issue? 

@zach - Done.


This theme was created prior to the Banzai release – unfortunately, we do not support editing of themes created prior to the Banzai release using the Theme Composer. You will need to create a new theme using Banzai’s Theme Composer.