Table (with scrolling on) minimizes on rendering the first time

This is the use case: I have two identical tables, one with Read only, the other with Edit. I have a buttom set with a custom Edit and Cancel button.
When I click edit, it changes a value in a custom Model to On and Renders the Edit only table. On Default and when I press cancel , it renders only the Read-only table.

Everything works fine Except(!) when I have scrolling on for the table. On page load or first time load, the editable table minimized to one row.
If I press Edit, then cancel and then edit again, it renders correctly with scrolling enabled.

So this seems strange as it does work on second try and I can’t figure out why.

I’ve reproduced the error on a simple page and attached screenshot and XML. Never mind the format etc.

this is the Screenshot after Page load when I press edit. See the scroll bars on the right side of the header, it does show all 5 rows.

This is after I press Edit, Cancel and then Edit again it works

Any suggestions why this happens?
I guess there might be JS to avoid having 2 tables, I’m just not an expert in JS and this worked fine until I added scrolling.
I’m now just not using scrolling, slightly annoying if the table gets too long, but I can live with it.



Here is the XML:

AccountFields <p>Right hand side responsive information</p>

Two Questions:

  1. What version are you running?

  2. Does this XML below work? I believe it wasn’t working the first time because the model wasn’t being queried. Thus, it would work after cancelling, but not before. This works on my end but I ask which version you are running because maybe if it doesn’t work on your end, there could be a problem there.



<p>Right hand side responsive information</p>

Hi Stephen,

1) Version 10.0.2

2) Your solution works by adding an action to query the model (again).
If you load my page you will see that it does load the data, but somehow on first load it minimized the table size to just the header. So you can scroll and it does show all the data, but only 1 row is visible, but upon second load/query it seems to adjus the size correctly.

The solution works for me, but I do somehow feel that it is strange that it needs an additional action as it does load the data.

It is strange behavior. I see that scrolling down does show the data. I didn’t see that to begin with. Another solution is the following: Deselect the Allow Scroll Bars.

I’m puzzled why querying the model worked. Don’t get me wrong, I’m glad that it worked, but I don’t think I can tell you why.

I’ll notify the Developers of this tomorrow and see if they can provide any more insight. Thanks for bringing this to our attention

Hi Stephen,

I identified the Selection of “Allow Scroll Bars” as the culprit. I added the scrolling that promped the issues so Deselecting the scroll bars is not really a solution if you want them :slight_smile:

It is strange that somehow the table with scroll behaves correctly only on the second query attempt, there is a workaround by querying the model again so its not the highest urgency.

Thanks for looking into it.