Table components with "Allow Scroll Bars" not showing any data until you click on stuff (Lightning 1

It’s also taking happening on the Membership tab, Administration tab and also one of the record pages (Invoice, I think) - but some of them currently have the re-render fix deployed (see above). I’ve removed this from the Membership tab so you can take a look.

I’ve created a new Lightning App tab (Skuid Test) and put the above XML in and it’s working fine. I then tried putting the Membership tab XML into the new page and it’s working fine… But now the old Membership page is also working. Very strange. Feel free to play with the Skuid Test tab and NewSkuidTest page.

I also often see this behaviour when I click the back button in the browser - the table on the previous page is now empty.

I think this may be related: http://community.skuid.com/skuid/topics/skuid-page-rendered-event-triggered-sequence-will-models-ha…

If it happens with the back button, that highly indicates its a caching issue. Have you cleared your cache since upgrading? 

Yep, so many times, and across many different computers and devices - sorry! I’ve also used fresh browsers not previously installed on one of these devices.

Here’s another example but with a very simple Skuid page produced by hopping to a different browser tab whilst the page loads:

https://darlston.vids.io/videos/1c9ddeb31e16edca94/skuid-table-issue

I can’t reproduce the behaviour I’m seeing above when I turn off scroll-bars on the table.

I’ve been able to reproduce this issue in 11.2.11. We’ll be working on it. Thank you again for posting this

Doing a hard reset of the cache in Chrome via View > Developer > Developer Tools > Application > “Clear Site Data” makes this problem intermittent instead of every time. It will work about 60% of the time instead of 0% of the time. At least, this is what we are seeing

Thanks Stephen, I’m glad you guys are seeing similar behaviour. It seems to be more likely to occur when larger volumes of data are being loaded into the page (though at volumes that wouldn’t have been an issue in the past). It’s like the rendering process on the table rows is waiting to be triggered only once the data has returned, but where this trips over for whatever reason (a bit more data or some other interruption) the trigger to display the rows never gets fired (or gets fired too soon?). It’s a new problem, as we’ve been doing stuff in Lightning for some time and it’s not been an issue before. I couldn’t tell you which version introduced it though, maybe 11.2.9? But I really don’t know.

In Charity App -> Finance/Membership tabs in org id 00D1t000000GWX9 (you’ve got access) you can reproduce it pretty much every time. Especially if you refresh the page from those tabs.

Hello! Can someone reach out to me on this please as I’ve just updated to the latest version of Skuid and I still have this issue on a very simple page.

I’ve granted login access (00D1w0000008acv) - head over to the Finance tab and you’ll see the issue (in Lightning). I’ve tried in Incognito mode etc. and still the same thing:

This is a new Skuid page running on 12.0.6

Ah! I’ve cracked it! No idea why this might be but I’ve isolated the issue to a row action, and specifically a row action using the FontAwesome 4 icon set. e.g. set a row action like in the screenshot below and use “sk-webicon-font-awesome:external-link-square” as the icon. The whole table breaks! This has caused me hours of frustration :frowning:

So I assume there’s a problem with how Skuid is accessing this particular icon set as part of the component render? It doesn’t grab the resource in time and the table row rendering fails. Anyway - hopefully y’all can replicate.

Actually no! I still have this issue! Can someone from Skuid please set up a screen share so we can go through this.

Thanks for this - another thing I’ve noticed, possibly related - if you refresh a page with a table (or open it for the first time) and then whilst the Skuid blue circle spins as the Skuid component loads navigate to a different browser tab - wait… - go back, no table rows. This is true for a very simple table and is easy to replicate.

Hello! I was wondering if there had been any updates on this?

Louis, seems like I can’t reproduce this in version 12.0.11, which version do you currently use?