Table components with "Allow Scroll Bars" not showing any data until you click on stuff (Lightning 1

^ as described above. This is quite a big one for us. Seems maybe to only affect new pages?

If there’s a quick css fix we can add to the page could someone let us know?



This is what it looks like:

Did we not have a bunch of extra conversation on this thread? I wonder if maybe I’m just losing my mind.

Any ideas what’s going on here? Not re. the losing of my mind but re. the losing of some of the posts on this page. I’m not sure if you saw my responses to your responses. I’m still having this issue even with the XML you provided to me (remove the table height property). Can someone please get back to me on this?

Can someone from Skuid please help with this? It’s getting quite urgent.

It also seems to happen to the table component in Lightning when you click onto a record in that table and then click the back button in the browser - when you navigate back to the previous record all the rows are removed and only show up again when you click on something in the table component. Interestingly - in all these cases - opening the Chrome Developer Tools forces the rows to pop back in. Bizarre. Same in Firefox.

I haven’t been able to reproduce this problem. Can you share your XML of the problem?

Hi Stephen, yes - absolutely. This XML is used in a fresh 11.2.9 install using the Skuid Lightning Component in a record detail page (custom object). Also about to provide login access. Thank you!

<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" useviewportmeta="true" showheader="true">
        <model id="OppsModel" limit="20" query="true" createrowifnonefound="false" datasource="salesforce" sobject="Opportunity">
                <field id="AccountId"/>
                <field id="Account.Name"/>
                <field id="Amount"/>
                <field id="CloseDate"/>
                <field id="Description"/>
                <field id="Fiscal"/>
                <field id="Id"/>
                <field id="Type"/>
        <skootable showconditions="true" showsavecancel="true" showerrorsinline="true" searchmethod="server" searchbox="true" showexportbuttons="false" hideheader="false" hidefooter="false" pagesize="100" alwaysresetpagination="false" createrecords="true" model="OppsModel" buttonposition="" mode="read" allowcolumnreordering="true" responsive="true" uniqueid="sk-3izY-296" allowscrollbars="true" floatheader="true" freezeleftcolumns="true" columnstofreeze="1">
                <field id="AccountId" uniqueid="fi-3izY-297"/>
                <field id="Account.Name" uniqueid="fi-3izY-298"/>
                <field id="Amount" uniqueid="fi-3izY-299"/>
                <field id="CloseDate" uniqueid="fi-3izY-300"/>
                <field id="Description" uniqueid="fi-3izY-301"/>
                <field id="Fiscal" uniqueid="fi-3izY-303"/>
                <field id="Type" uniqueid="fi-3izY-305"/>
                <action type="edit"/>
                <action type="delete"/>
            <massactions usefirstitemasdefault="true">
                <action type="massupdate"/>
                <action type="massdelete"/>
                <view type="standard"/>
        <actionsequences uniqueid="sk-3izS-249"/>
        <styleitem type="background" bgtype="none"/>

This is a known Skuid issue. We’ll notify here when a fix goes live.

Allow Scroll Bars" on Tables in Lightning won’t show the data in the table on page load unless “Max Table Height (Optional)” is set. And if it is set, it won’t appear properly.

My temporary fix for this is a “Skuid Page:Rendered” triggered snippet which waits for a second and then re-renders the table via component id:

setTimeout(function () {
}, 1000);```

Any updates on this? It’s driving me round the bend.

It should be coming out in the next release or the one after that.

Hello Stephen - being able to show a table on a Skuid page, to me, seems completely fundamental - can we please have a date by which this will be fixed?

Looks like this was addressed in the latest release - will install and test and let you know if there any issues :slight_smile:

I’m afraid this fix hasn’t worked - I still have exactly the same issue - could I get an update? Cheers! I’ve tried this after clearing all cookies etc. 

Have you tried in 11.2.11? That is suppose to have the fix

Yeah, that’s the release I’m testing. I saw it in the release notes but maybe the fix didn’t make it in?

The fix made it in and the XML on this post is being used as the source of reproduction. I just tried the reproduction page and see that it is working in our org. We currently have no reproduction of this.

What Instance are you in? What browser and version? What kind of computer are you using? 

Hi Stephen,

I’ve done further testing and the issue is on Mac Chrome, Mac Firefox and Windows Edge - they’re just the browsers I’ve tested - so it’s not related to my setup.

We’re seeing it in both Production and in a Dev Org.

Sometimes it now works if you visit a different skuid page first, but it’s inconsistent.

I’ve granted login access (00D1t000000GWX9) - you can reproduce by going to the “Charity App” and then clicking the “Finance” tab (in Lighting obvs).

I was able to login and see what you’re seeing? Is this the only place you’ve seen this happen or are there other locations. Can you reproduce it using standard objects and fields? So far I can’t replicate it outside your org