Zero skuid pages will load (i.e. my entire system is down). What is “Row with duplicate Name at index: 9”. Page Assignments won’t even load. Nothing.

escalating this in case it’s not obvious, but this is absolutely urgent being that it means our entire SFDC is unusable as of the past hour (at least).

I checked a couple of our customers orgs and none of them have this problem. I also checked the SFDC maintenance schedule and the only thing done today are live agent maintenance updates. Are Dylan and Will on different orgs or on the same? Did you do any changes, updates etc that might have been the cause for this? If you check the dev Console in the browser do you get any clues about the cause? 

Do you get any javascript errors in the console?

Do you use a Master page?

What have you installed or updated in the last day?

Can you open the page in the App Composer?  If so, do you see any errors?

We’re both in the same org. Screenshot of the errors below. Yes, we do use a master page. It started last night when I tried cloning a theme and saving. Not sure if that’s what caused it or the timing was just coincidence.

Thanks for the screenshot! We’ll take a look and figure out how to resolve the issue.

What do you mean by app composer? The page editor? If so, no. Literally every skuid related page it broken. Page editor, page assignments, skuid settings, skuid central, etc. The Skuid “app” won’t even load. Here’s another error from the console that appears right before the errors above.

Go to the custom settings page and see if there are two themes with the same name.


Hi Will,

I feel your pain.  Seems Josh is on it so hang in there.


I’ve granted login access.  Please let me know what’s going on.

You are by freaking hero.  That was it.  I deleted the duplicate and that fixed it.

Fantastic!!! Good to hear.

Very strange though. It let you save the theme with the same name? Do you remember naming as such?

Seriously, thank you so much.  Love this community.

At least it was Friday night and not MOnday morning when this happened. :smiley:

I think that I cloned a theme renamed and saved.  For some reason, the save just kept spinning so I opened a new tab and did the same thing again.  This time it let me save.  I went back to the original tab, which was still spinning so I just closed it out.  I guess the first one went through at some point.

Yup. That description should certainly help Josh and the gang figure out what happened.

Thanks Will. Salesforce data rules should have prevented this from happening, but it’s been known to occur very rarely: Unfortunately, there’s not much we’d be able to do to prevent this (since it’s supposed to be guarded against at the database level). Your steps to repair it were exactly right… Pat beat us to the punch, but that’s why he’s a community champion. :)