System Admin doesn't have permisison to remove, add new or modify pages?

Although I just purchased a year of Skuid, I am running a free trial until that goes through. Everytime I try to create a new page, I get this error: “You do not have permission to remove, add new, or modify existing Pages in the Squid Module.” Am I missing something? (System Admin, all permissions… never had this issue before but haven’t used Skuid since the new UI update).

The Skuid Module is a set of pages included in Skuid that actually do the Skuid Work. We use Skuid ourselves to build the pages that you use to build pages. How recursive…

Somehow you have set the module filter so it is only showing the Skuid Module. Change it back to “no module”. Now you will be able to see all the pages you have created and you will be able to add new ones.

Hope that works.

Hi Rob,

Same error for me too, tried your solution did not work. Any other solution?
P.S : I am using Developer sandbox.

Can you post a screenshot of your pages page?  Especially with any pages created that were not part of the skuid package that you are not able to edit?  

Then maybe post a screenshot of what it looks like when you try to create a new page (and get the error message). 

Thanks. 

we too facing the same error
developer sandbox