strange delete behaviour

I’m getting some strange behaviour when I use the standard skuid ‘delete’ button on an opportunity detail page. see below:



I’ve got five different choices.  Only the first and last ones are relevant to this skuid page. The other ones are asking me to delete things that have no relation to this particular page - i.e. there is no model containing these records/objects.

I may have marked them for deletion previously, so I tried logging out and logging in again, I also tried logging in using a different pc and still got the same behaviour.

Any ideas as to why this might be happening?




Can you confirm when this happens that you do not have other Models on the page with records flagged for deletion? For instance, maybe add Tables to the page on the Aircraft Type, Airport, and Aircraft Models and check to see if they have rows that are flagged for deletion when you click to delete the Operation?

Woops…I’ll have to correct myself when I say that the 3 objects in the middle have no relation to the page. I’m loading a new row in each of those models, but never saving the values entered into them - only using user-entered values to apply them into filter conditions on one of the ‘relevant’ models.

The 3 models in the middle haven’t been marked for deletion though, which is the message I’m getting. They are simply new rows which may or may not have values in them but will not be saved to the server.

It’s as if the ‘delete’ action on the Opportunity object is registering that there are unsaved changes on other objects, and thinking that they have been marked for deletion…

…and to answer your actual question :slight_smile:  it behaves as expected when the other models are removed from the page, ie it deletes the opportunity as expected without the additional options.

Still hasn’t been fixed. It should only display records marked for deletion not unsaved records.