Sort icon not displaying in table column headings

I have a table where I have allowed sorting, but the icon for sorting in the column headings is not displaying correctly. If I select “circular” as the style, I get an empty circle and the hover text says “1 of 2” as opposed to “Sort By” which is does for some other columns. Regardless of what style I choose, the icon itself does not appear.

Jamie - what version of Skuid are you running?

And to clarify - you are setting the “Circular” style in the DSS configuration for the table - right?

Hi. We are on version 14.4.6 and yes, I am setting the circular style (not my preference but just testing) from within the DSS configuration for the table. Under Nested Components > Column Header Sort (Button)

Here is a guess: The text in the circular button definition is white. I’ve changed my sort buttons over to another circular definition and while weird – the buttons still work.

(IF you want really weird - make those buttons Destructive!!)

Screen Shot 2022-02-16 at 8.50.15 PM

So what ended up being the issue was that I was on a slightly older version of Skuid. Once I upgraded and then also updated all of our styles, I was able to see the buttons.

This issue popped up again. It looks like I can see the icons when previewing pages but when I deploy the page and display it in a Salesforce tab, I don’t see the icons. Any thoughts on a way around this?