Skuid session expired after logging in

Hi community~

So sorry this is still not resolved yet, still working through it with Salesforce … Here’s a question from them: when your users encounter this problem, what browser are they using? Is it any better from a different browser (they recommended Chrome)?

Thanks!
Karen

We use chrome across our org to access SFDC. I personally have tested Edge and had the same issue.

We also use Chrome. Haven’t tried anything else.

We all use Chrome

Hi again community~

I hate to do this but Salesforce is asking for

  • a test user in an affected org 
  • a GoToMeeting with an affected user (and me) to see the behavior
If you are okay with both of the above and are available tomorrow sometime between 9-11 am, 11:30 am-12:30 pm, or 2-3 pm PST, please let me know and we can coordinate and get the details offline.

Thanks so much for your support and patience!!!
Karen

Probably not much help, but here goes:

I’m having this issue as well. From the error message, it looks like Skuid is getting (or thinks it is getting) a HTML response - so the error message is "Error parsing json response: Unexpected token <"

I open a page in the page editor and open the Chrome dev console, and monitor the network tab. I can see constant pings to apexremote. Once I get the pop up about “Are you sure you want to leave?”, I check the network calls - they are all 200, and they all look like the received a JSON response. I thought maybe one of them would show a different code (e.g. 401 Unavailable?), or at least one of them would have received html that looked like a “You need to login” page.

The curious thing is, I don’t actually seem to be logged out, so I don’t think the session has actually expired. If I ignore the message, I can carry on editing the page and even save it. Therefore, I think if Skuid checked multiple times that the session was invalid and only warned after, say, 3 times, I wonder if this could be a temporary fix to the problem?

Our org just started receiving this error in our pop ups as well

We are experiencing the same issue. Our users are using both IE and Chrome, though mostly Chrome and the timeout is happening with both browsers.

We have been having the same issue for the last week, with only 5 known users out of 97. I cannot get the error to replicate for me, but I do have screenshots sent from my users. We have asked a series of questions and know that they are all using Chrome, though some went and tried IE after multiple errors, and the time out is happening within seconds sometimes. I passed on Gary’s info about just ignoring it, so I will see if that works for them.

Any update on this?

I am also having the same issue on a skuid page. I believe its happening when the page/master page has enabled the “Enable Page Caching”. When I enable it I get this error. here is the use case:

Enable the page Caching
log in as a user to hit the page (no error pops up)
Do any tasks and log out
Log back again to hit the page (Error pop up occurs)

in Salesforce, The session is 8 hours and works fine.

I don’t use page caching and can reproduce the issue by logging into salesforce, going on a skuid page and going to another tab for 30 minutes and then coming back.

None of our pages that are having issues have page caching enabled either…

This is exactly what’s happening with us.

the “error parsing json response…” is also what we’re getting. 

Same here…we are not using page caching.

We are not using page caching where most of these errors occur. However, there are several page includes involved on pages where this seems to be happening. Not sure if it is related. 

Tanzir~

Thanks for narrowing it down to that for your situation. Following your steps, I am able to reproduce the issue by. However, once the error message goes away, I am able to work on the page and save any changes. Is this what you are seeing as well? 

Thanks!
Karen

I was going to post yesterday that I thought the problem had gone away, but then I did have a few issues that looked like the same problem. However, I have so many tabs open (and the security rules in the org are fairly strict) that they may have been time outs.

Is it worth the people experiencing this stating which pods we are on? I work mainly in CS81, and it’s where I’ve seen the issue, but like I say, in the last couple of days, the problem may have gone away.

I’ve had this error come up on both Firefox and Chrome.