Skuid Platform logs me out every couple of minutes

I’m trying to develop on a Skuid Platform Trial site, but it logs me out almost immediately after logging in. I’ve tried both Chrome and Firefox. When I try to save changes to a page is says my session has expired. 

This seems to happen intermediately. Sometimes I can work in it for a hour without it happening, but then other times I can’t work in it at all because it constantly logs me out.

Not sure how to go about fixing this? Any ideas? 

Hi, Sam.

Two things I can think of:

  1. What is your session timeout set to? Find that at Settings > Site > Security > Session Options. Try upping it and see if it resolves issue.
  2. What data source type are you connecting to in your page?
Thanks! Sarah

Hi Sarah,

1. Looks like Session timeout is set to 30 minutes.
2. I’m connecting a few different data sources. PostgreSQL, Salesforce, and REST.

I believe I had this problem before I had added any data sources.

Just now, trying to get this information, it logged me out about 10 times before I could get to the pages needed. I ended up waiting a few minutes, made sure I had no tabs open of the platform and then I was finally able to log-in and get to the page.

I can sometimes get around it by only having 1 tab open. I have to make sure to use the “Preview” button every time I want to see how a page changed as refreshing the previewed window causes it to log me out.

I hope this helps solve this problem.

Thank you,


I screen recorded the problem as it’s hard to explain. But, I can’t use Skuid Platform at all now and I’m on a deadline for this, so I really appreciate any help!

Thanks for the screen recording, Sam. That helps.

We have seen this error pop up when the REST data source needs some configuration love, specifically with the URLs.

Double-check that your URL / Endpoint for your REST data source settings does NOT have your URL merge parameter in it–that should be in the conditions in the settings, or within the data source URL field in the model on the page.

Check out this recording at minute 1:00 for an example with a sample source:

There is also a ton more here in our Docs, but splitting out the merge parameter has solved for this before:

If that doesn’t do the trick, let us know.

Good luck!

When I click in the video it asks me to sign in for Skuid.slack, but I don’t think I am in that Slack workspace. I am in the skuidcommunity.slack workspace though. 

I actually don’t need the REST data source anymore, so I can remove that. I also noticed I have an ODATA Sample Data source. 

Problem is now that I can’t even get into my account and click on anything. It asks me to login again right away. I recorded a video of it here

I'll try again tomorrow and see if it's any better.

Update regarding this behavior: as a security precaution, by default we only allow a session to be valid for a single IP address and user agent string (device). If your network situation is such that your IP address will be changing frequently, contact Skuid support and we will turn off this additional security feature.