Skuid Mobile Add Google Map Link Button

In Salesforce1 App and Skuid Mobile I do not see an option for Buttons or Links (for instance I have a link that I use on the Desktop Skuid pages that is{!Account.House_Street__c}+{!Account.House_City__c}+…

I pasted that into a Mobile Skuid button and it just sat there when I clicked on it.  Whereas if I enter it opens right up.  I also tried tweaking the field lookups to use mustache instead and I made sure the fields where in my model i.e.{{House_Street__c}}+{{House_City__c}}+{{House_State__c}}&om=1

What is my best option for taking fields from an object and incorporating them into a Button with an action of “Go to URL” in Skuid Mobile?


Rich, Maybe I’m misunderstanding your question. If you add a button to your mobile page, one of the on tap actions is go to url.

Sorry, I am using the “Go To URL” button. But it does not seem to interpret the items within the mustache. I tried a google maps URL with the street, city, and state appended to it using {!Account_House_Street__c} and I also tried {{House_Street__c}} but in both instance the button just sat their, it did not open any web page. The URL I pasted in came from a Link that is working on the main pages so I believe the URL is good. If I entered a dumb reference like it worked fine.

So my question is, does the Skuid Mobile Button “Go To URL” recognize and interpret field references, specifically fields within mustache? If so what am I doing wrong.

Rich: The Go To URL feature will interpret field references.  Here are a few caveats. 

1. The syntax you are using above is the standard Salesforce data merge syntax.  IE:  {!FieldName}  In Skuid you need to use the {{double}} or {{{triple}}} mustache syntax.  For URL’s,  I’d reccomend triple because you are only interested in the data and not in our rendering functions. 

2. You need to make sure that the model data is available to the button.  If the button is in a card on a deck,  then any data from the model that the deck is bound to will be available simply by using the syntax  {{{FieldName}}}   However if the button is in a header, or in some place where there is not a model context, you will have to use the global data merge syntax:  {{$}}

Hope those hints get you going in the right direction. 

Alright, I just did some more tests and stumbled onto an issue.  If I create a button called “Map It” with a “Go to URL” on tap action with the URL of  with no field references the Skuid App on the iphone opens up in a new window without any problem.  When I add the field references{{House_Street__c}}+{{House_City__c}}+{{House_State_… using double mustache the App Button on the mobile phone will not do anything.  No window pops up etc.  

Out of curiosity I previewed the skuid mobile page on my desktop computer and hit the “Map It” button and it worked perfectly using the double mustache.  So the double mustache merge syntax is working great on a computer, but is breaking something when I try it on my phone.  Any thoughts?

Rich.  I’ve been able to reproduce this issue in the Salesforce1 app.  We will take a look and see if there is anything we can do to correct this,  or if its a limitation of the implementation path that SF1 has given us. 

has this been resolved?