Skuid Lightning: Theme Issues on Refresh

Just testing some things on the new release and I noticed an issue on refreshing a page. This happens intermittently so I’ve been unable to pinpoint the cause. What’s happening is the theme sometimes displays correctly, and when refreshed it shows the buggy lightning theme view. 

Also, whenever you switch over to the Lightning Theme as the org default, it shows that buggy view across the board. All page support files have been generated and this only started showing up when we updated to 11.0.1 this morning.

Have you Updated your Out of Date Themes since upgrading?

I ran the update out of date themes over lunch since it was taking a long time to complete. But I don’t have the option to update out of date themes anymore when selecting all so i’d assume they have been. 

It can take a while. You mentioned it is intermittent which is extraordinarily frustrating to troubleshoot. Let me know if you see the problem again after updating out of date themes.

You’re correct: if you don’t see the button, they should be fully up to date.

Ok, i’ll let everything settle down and continue troubleshooting tomorrow

I let everything settle down and the issue is still coming up. Below is a sample of the frequency this happens.

At about ~40 seconds in you’ll see another random error pouup on the right hand side “Missing Data Source: salesforce”. That happens much less frequently but still does occur intermittently.

Just upgraded to the newest version to test, this issue still persists when refreshing a record page. 

Could you re-upload that with narration as to what we’re looking at / what we should be seeing v what we are seeing?

Sorry it took me so long to circle back, the issue is the same as above this video just walks through that all themes were updated and all page support files generated.

I just updated to 11.0.3 and the refresh issue is still there. Upon page load or refreshing, the theme randomly breaks is the best explanation. I’ll upload a narrated video shortly but the behavior is the same as the previous videos.

Hi Erik, if the page that’s behaving this way includes any child pages or page includes, can you make sure all of those pages are using the same theme as the parent/master page? I’ve seen some strange behavior when a child page uses a different theme from its parent - at first the pages all look okay, but the child page may load after the parent page, or it may be refreshed at some point, and that can cause the child page’s theme to conflict with the parent theme. 

Checked through the XML for all includes and made sure they were all set to ‘Default’ and the refreshing issue still showed up. One thing i did notice about the page includes, some of them are missing the ‘Module’ they’re in. Could this have something to do with it?


<includepanel type="skuid" uniqueid="sk-1yveH1-914" pagename="Lightning_Invoice_CreateNew" module=""  

Should be;

<includepanel type="skuid" uniqueid="sk-1yveH1-914"  pagename="Lightning_Invoice_CreateNew" module="Lightning Pages" 

Here’s an example of one of the includes on page that’s correct

<includepanel type="skuid" uniqueid="sk-3_73hv-786" pagename="Lightning_PaymentCreation" module="Lightning Pages" 

That’s an interesting detail. I’m not sure what kind of affect inconsistent module values would have on the pages’ behavior at runtime. Does it seem like there’s a pattern across other pages that have no module value, but are included with pages that do?
A second question: can you add the Lightning_Invoice_CreateNew page to the Lightning Pages module, to see if it will fix/improve the behavior?

So thats the quirk, the Lightning_Invoice_CreateNew page actually was in the Lightning Pages module. I went through and updated the XML with the appropriate module for every include and the refresh issue still showed up.

I’ll backup the page and try removing all the page includes to see it’s related to the issue. 
Edit Removed all the page includes and it still showed up 

Ok so I’ve done some more troubleshooting. It appears this only happens in record detail pages & that page includes doesn’t affect it. Our Leads Detail page has no page includes and the behavior still persists. 

When loading a detail page in the Skuid page preview, the theme is correct 100% of the time.

Also, this has got to have something to do with Lightning because these same exact pages are currently used in our classic instance with no issues. 

Eventually I was unable to determine what was causing this issue. I re-built the theme we’ve been using for over a year and set that as the new default. It appears that has done the trick but as to cause it’d have to be something wrong with the theme it’s self. 

Can mark this resolved now as the refresh issue no longer appears with the new theme. 

Eric, I’m sorry we weren’t able to determine the underlying issue, but I am glad you were able to come to a resolution. Thank you also for closing the loop on the conversation. I will mark this as resolved, but if the issue resurfaces, or if another customer runs into something similar, we’ll have this as context to continue investigating. 

No worries it all worked out, the new theme only took an hour or so to build and it’s much cleaner than before :)