Skuid 11.1.13 Picklist Bug with Special Characters

Hey team,

We’re on the Skuid 11.1.13 for Salesforce and oops–some of our picklists are now broken which were working in all prior versions including 11.1.11.

The issue appears to be with special characters such as an ampersand (&) being in the picklist. These are showing up blank to the users in Skuid however when they save it looks like they’re not being encoded properly so they show up as “&”.

Example: “Joint & Several” picklist is blank in Skuid, when saved becomes “Joint & Several” in the database.

Help me Skuid community, you’re my only hope! :slight_smile:

Thank you,


Hi Dan,

By chance are you using our Field Renderer APIs found here:

Thank you,


Hey Josh,

I’m not using a custom render or Javascript to display these fields if that’s what you’re asking. All of my fields are set with a Field Renderer option of “Standard”.

Thank you,


Update: 11.1.13 also breaks my picklists with an apostrophe too. These are showing up as blank along with the ampersand scenario.

This is pretty negatively impacting our business right now :frowning:

Still broken if I change from Standard render to custom. Tested further and changed from Standard render to custom using the following; all of which also produce the same bad picklists:


skuid.ui.renderers[‘PICKLIST’][‘edit’](field, value);


skuid.ui.fieldRenderers[‘PICKLIST’][‘edit’](field, value);


skuid.ui.getFieldRenderer[‘PICKLIST’].edit(field, value);

Temporary Workaround

Create a custom render with the following snippet:

var $ = skuid.$;
var field = arguments[0];
var value = skuid.utils.decodeHTML(arguments[1]);

skuid.ui.getFieldRenderer(field.metadata.displaytype)[field.mode](field, skuid.utils.decodeHTML(value));

Change your fields from Standard render to Custom and select whatever you name your snippet. I called mine ‘htmlEscapeRender’.

Skuid team–please fix in a maintenance release!

Hi Dan,

Thank you for the added testing you did here. I also did some testing in a Dev Org of mine, running 11.1.1, and for some reason I cannot replicate the behavior you are seeing in my test page.

I’m curious if you could possibly try to create a really simple page in Skuid that brings in a field editor, table, etc to look at the picklist that is rendering oddly to see if the issue exists on that simpler page? If the issue persists there as well, I’d love to take a deeper look at the page XML for the simple page to see if the issue can be reproduced in my Org.

Thank you,


Josh, reminder… I’m on 11.1.13 – which is where the break started. Previously 11.1.11 worked fine. Even my temp fix kind of sucks it’s not 100%.

Long story short, Skuid isn’t decoding some special characters in HTML properly starting with 11.1.13.


Apologies, that was a typo on my part! I meant to pass along that my Org is in 11.1.13 regarding the tests I’ve done so far. If you could try a very simple page as mentioned above that would be very helpful for me to proceed with digging a bit deeper here.



Here’s a test you can recreate pretty easily:

  1. Go to the standard Account object and create two new picklist fields:

A & B


  1. Create a Skuid page with this XML:

Results :

Both picklists are showing up incorrectly as seen below:

Changing themes, caching, etc. had no influence on it as best I could tell.

Thank you,


Hi again Dan,

This is really strange, I still don’t see the issue happening in my Org. My tests thus far have all been done in Chrome, are you perhaps in another browser when this occurs? I am doubting that this would be a cause, but I’d like to rule it out to be safe.



Josh, I’m using the latest version of 64-bit Chrome however we have a variety of around 100 users who are reporting picklist problems. They’re using anything from IE11 (yuck), Edge and/or Chrome. Chrome is the one I recommend of course! :slight_smile:

Browser Snapshot:

As noted before this definitely started after I upgraded to 11.1.13 – I did minor regression testing to ensure pages worked but obviously this wasn’t caught :frowning:

Can we get this escalated, please?

I’m continuing to get new reports of breakage across our business. This is causing an extreme amount of frustration for my users who are reporting anything from missing to broken picklist values.

Hi Dan,

I am going to be reaching out to you directly to try and take a deeper look at this in your Org. I’ll be in touch shortly!



This reply was created from a merged topic originally titled Ui- Only Picklist. We have several pages built in Skuid that utilize Ui-Only fields. Since upgrading to Millau (11.1.13) these picklists are all rendering blank. 

This is causing a lot of issues for us as we uses these on pages that get a ton of daily traffic and those fields are essential to the page.

Any ideas what is causing them to load empty?


We have upgraded our Production org today to 11.1.13 and have the same issue. A salesforce picklist a value of “PrePaid > $2,500” is not showing up to the user - they render as blank choices. If you pick the blank value where this value should be, it saves it as “PrePaid > $2,500”.

Blank values in this list all contain special characters. But selecting them and saving will actually save a value to the record, just incorrect with the special characters.

I find that if you remove the special characters from the API name of the picklist value the issue goes away after a browser close and restart.

So I changed:
Label: PrePaid > $750
API: PrePaid > $750

Label: PrePaid > $750
API: PrePaid 750

And the issue goes away.


We are also experiencing this issue as well. Eliminating all special characters from picklist values is not an option. This need to be repaired by Skuid.

Can we get an update on this issue?  This is still a problem for us, even though we updated the API name to make the picklist choices show up.  The field value labels still have (and need) the special characters, and the user side is still showing the improper encoding.

This was discovered by our customers because we send quote documents out that are sourced from a skuid page, and they are seeing things like “PrePaid > $2,500” on their quote proposal, instead of “PrePaid > $2,500”

Hi Chandra,

This was fixed for me in 11.2.2 – I’m not sure if you’re on that version but I tested in my sandbox and then deployed to production once confirmed! :slight_smile:

Best of luck!