Sharepoint With OAuth External Data Source Configuration

I’m attempting to configure an External Data Source to Sharepoint using OAuth.  When I type in an “external object name”, the OAuth popup appears, I input my credentials and it dismisses.  When I type something in to the External Data Source textbox again, the same thing occurs.  It does not appear that any network activity is occurring as nothing shows up in the Network log.

I’ve created a connected app in Sharepoint (note that only one callback URL is permitted and I used the skuid_oauthcallback one) as well as an Auth Provider in Skuid and a Model Service.

I’m fairly certain that I’m mis-configuring something but I’m not really sure what I have misconfigured as there are no error messages/exceptions/etc. 

Has anyone been able to configure this successfully?

Skuid Team - Would it be possible to update the Sharepoint tutorial with a full set of steps to use OAuth & Sharepoint?  It’s incredibly difficult to troubleshoot this currently given how many layers are involved and no way to “test” individual layers.

Thank you!

Hey, Barry. I’m trying to think of what could be misconfigured. Getting the OAuth popup sounds like you are close. The lack of network activity is perplexing though, and of course, we could have a bug somewhere in there too. Any chance you could grant us login access so that we could have a look at the Skuid configuration? We won’t be able to check anything other than the Skuid setup (since we won’t have valid creds for that popup), but we can at least have a look at that bit and maybe have an idea of what to look at next.

Hi J - Thanks for taking a look.  I’ve granted login access and will email Org Id.  If you want to jump on  GTM, just let me know.  Thanks!

I’ve tried this again with Update 7 but unfortunately I’m still unable to successfully connect to Sharepoint.  I’ve attempted to understand all the new settings as best I could but when I search for an “External Object Name”, no results are returned and no errors are displayed.

When inspecting the “network tab, I do see an apexremote call.  The result of the call appears to be an exception:

[{“statusCode”:500,“type”:“exception”,“ref”:false,“action”:“Unknown”,“method”:“Unknown”,“message”:“Content type ‘null’ not supported for Visualforce remoting request. Expected ‘application/json’.”,“where”:”",“data”:"",“vfTx”:true,“vfDbg”:true}]

It is very likely that I have something misconfigured but unfortunately, there is no way for me to know exactly what is wrong if it is a misconfiguration because there are no errors of any type other than the above and the docs don’t explain how to properly configure this scenario currently.

Would someone be able to take a look at this please?

Barry, I’m writing a tutorial on this, but the only supported way to connect to SharePoint Online with OAuth with Skuid is to create a new Authentication Provider that uses “SharePoint Online” as its Provider Type. But there’s a few more steps involved on the SharePoint Online end as well to ensure that you’re configured exactly correctly.

So stay tuned for the tutorial.

Thanks Zach.  I started fresh with a new SO app, Skuid Auth Provider (using SO) and Skuid Model service but fell short.  Looking forward to the tutorial, thanks!

This tutorial describes how to use Skuid Banzai Update 7 to connect to SharePoint Online using an OAuth 2.0 Authentication Provider:

Connect to SharePoint Online with OAuth 2.0

Hey Zach -

Thanks for posting the tutorial.  I’ve gone through it and unfortunately, am still encountering issues and unable to connect to SP via Skuid.

I believe the problem likely lies in the fact that I’m using a Site Collection.  I’ve adjusted all the URLs to account for that but still no dice.

Would you be able to login with me and take a look please?

Barry, I’ll follow up with you offline to schedule a time.

Awesome, thanks Zach!