salesforce1 mobile app goes to skuid desktop pages?

Haven’t implemented too many mobile pages, but I’m not sure I understand how this happened. I installed Skuid CRM and updated the buttons accordingly.

Desktop browser works as expected.

Salesforce1 app now goes to the same pages though? What am I missing? I want salesforce1 to use the standard pages and not Skuid. How do I fix this?

This is pretty interesting Pat.  When I use Salesforce1 to access regular object tab pages - I get the SF1 interface - even though the tabs have been overwritten as Skuid pages.   Now - if they are VisualForce tabs - you do get the Skuid page. 

I’m really not sure what the difference could be. 

This is on my own salesforce org as an ISV. Granting you rights. Here is the org id.

Was there a solution to this? I am having this issue in our org but only with the contact (detial) object for some reason. 

Is the contact tab on Salesforce1 accessing a VF page that is overriding the Contact View?  Are others just standard SF Pages?  We’d expect the standard pages to use SFI layouts,  while the VF pages will get the Desktop Skuid pages. 

Yes, The Contact tab is accessing a VF page as an override. So are all the other standard tabs. That is why I cant figure out why the contact tab is doing it but not the others.

Just had the same issue, and I just had to make sure my VF pages for the overrides do not have “Available for Salesforce mobile apps” checked. Does that fix it?

Yes - I think that fixes it. 

We have a similar issue. We installed Skuid CRM and with those objects (Accounts, Opportunities, Leads, Cases), even though “Available for Salesforce mobile apps” is NOT checked, Salesforce1 on iOS is still diverting to the desktop Skuid detail page. (We just want those records to show the standard compact layout in SF1).

Any assistance would be appreciated.  

Guys: In a Partner specific Chatter feed I have read that VF pages designed for Aloha do not work properly when they are invoked in SF1.  This is a known issue with no workaround.  I have asked for specific published issue that I can point you to but I can find none. 

Rob, Thanks for the feedback.  I’m wondering why this is only effecting the objects associated with the Skuid CRM Package (Accounts, Contracts, Opportunities,  Cases, Leads).  Other custom VF pages we have set up for Skuid desktop are working correctly on SF1 (ie not loading).


Hmm.  We’ll keep looking at this Nicholas.  There may in fact be somthing on our end that can correct this.  

Thanks Rob. We’ll wait to hear - fingers crossed.

Rob,  do you have any luck looking into this issue?  Nicholas

Hi Rob - did you have any luck on this?  Since Skuid for CRM is an installed package, we can’t modify the “available for Salesforce mobile apps and Lightning Pages” on the VisualForce pages (which is always checked).   Whilst Skuid for CRM is good for desktop,  it make the Salesforce1 (on a mobile) fairly useless, meaning we’ll probably need to disable the installed package and, I guess, build our own Skuid pages.  Would you have any guidance on this?  Do you plan to update your Skuid for CRM pages?

Thanks. Nicholas