Rockaway Error: Child record creation throws error "Required fields are missing: [Service Contract]

I recently upgraded to 8.15.8. I am receiving trouble tickets now due to an error message:
Required fields are missing [Service Contract] !( 8 inline.png “Image https//d2r1vs3d9006apcloudfrontnet/s3_images/1477940/RackMultipart20160903-60771-dregpg-ScreenClip__8__inlinepng1472861916”)
The service contract is the parent the service is the child.

It appears that Skuid is no longer able to pass the parent name and ID to the child record so the system will not save the record because the parent record is blank at save. This popup has worked for a couple of years with no issues.

I have three models on my page:
Account: with a condition to get the Account ID from the page URL (this bring in the client/account information.
NewServiceContract: the parent record has a condition to bring in the account record from the first row of the Account model.
NewServices: to add services to the service contract. With a condition to set the Service_Contract__c is the value of the ID field from the first row in NewServiceContract Model.
!( 9 inline.png)

In the past this has worked brilliantly. Now it won’t allow saving anything.

As mentioned, this method has been integral in creating this and other pages. Can you let me know the most seamless work around or give me an idea when this potentially can be fixed? I am concerned because I just created a whole new process that I am rolling out to 250 more users that just broke. I could create the Parent object and then create the children. But it was nice to create everything prior to the save. Any information will be helpful. Also the reason why it no longer passes the record to the children record.

Are there any other circumstances where this is going to cause problems so I can look for those scenarios proactively in my org?

Thank you for your help, and the tremendous product. I have said it many times but Skuid gave our company new life. We love it!

In my scenario both NewServices and NewServiceContract are included in the save.

Rich.  Sorry this has bit you.  In 8.15.8 there was a regression introduced that caused problems in certain scenarios that use Field from another Model conditions.  Multi object creation was one of these situations. 

We have released a patch that fixes this issue.  8.15.9 is available on  If you look in the release notes you’ll see reference to Skuid bug 2431. 

If you don’t want to upgrade to 15.9 there is a workaround.  You can go to the condition at hand and change its “if no row in source model then…” property to “Abort Query”   That has worked for me.

Thank you for your kind words about the product.  It is stories like yours that continue to make us excited about our work and convince us the vision.

Bless you Rob!  I installed 8.15.9 and we are up and running.  I know it is later where you are and possibly the start of a long weekend.  I appreciate you taking the time to comment after hours.  I would have had a long extended weekend trying to figure out work arounds so everyone would be good to go on Monday/Tuesday.  I can enjoy my Labor Day stress free now, that means alot.  Thank you Rob and the Developers who had just released the patch!