Rendering using Running User Attribute - User Role Id not working - possible bug?

I was trying to render a responsive grid using the Running User Attribute - User Role Id. I tried using the 18 digit value, the 15 digit value and the name of the Role itself but none of it worked.

I was looking at the XML

and I paused at sourceuserinfotype=“userroleid”. Having used $User.userRoleId in my javascripts snippets the past, I changed it to sourceuserinfotype=“userRoleId” and that worked.

We are currently using 10.0 and I am not sure if this has already been fixed in one of the releases that followed 10.0 - but if it hasn’t, I would request Skuid to fix this.

Can you elaborate on what ‘it’ was that you changed when you say:  I changed it to sourceuserinfotype=“userRoleId”

I changed sourceuserinfotype=“userroleid”

in

<rendercondition type=“fieldvalue” operator="=" enclosevalueinquotes=“true” sourcetype=“userinfo” nosourcerowbehavior=“deactivate” sourceuserinfotype=“userroleid” value=“00E61000000YQuyEAG”/>

to

sourceuserinfotype=“userRoleId”

and made it work.

Sneaky but clear as day. I’ll get a ticket written up for it now

I’m on 10.0.5 and unable to reproduce this issue. userroleid works for me on Google Chrome. What is your browser and operating system?

Windows 10 Enterprise - Chrome