reference search box does not have dropdown

Recently upgraded to 10.0.4 from 9.5.1.

I noticed that a reference field that produced a drop down in the previous version no longer will show as you start to type. I am fairly certain I have the reference field set up in the exact same manner, I have also tried removing the field from the page and readding it.

The image belows outlines that the “search” circle just spins and spins and does not eventually load.

My question is: Did this functionality change in the newest release? Or is the only way to select is through the magnify glass and select the item from that table.

The first image shows current functionality, the latter is the old functionality.

Thanks in advance for any help!


Strange. I have 10.0.4 as well and everything is working fine.

Okay, given that you are not experiencing this, I will take another shot at reconfiguring the fields and see if that helps. I have not tried changing my Display and Search template to see if this is causing an error. 

Okay, so it looks like it was something to do with using SOSL and not. I checked the box to use SOSL and selected all text fields (which in my case they were all text fields) and then I was able to see results. I am not sure why this is the case instead of just specifying which fields to search across. 

Glad that you’re able to use SOSL instead to resolve your issue, Richard! 

Pat, thanks for confirming that it is working as expected for you :) 

Hi Karen, I would like to point out that I would prefer not to use SOSL to complete this functionality, and appears that on a standard Contact to Account lookup, not using SOSL works in some capacity (I have not fully vetted the Search and Display Templates, but the drop down does appear). I am curious to know why a custom Lookup Field to another Custom Object is not functioning as intended. 

I can confirm this a problem where you will not receive the dropdown unless you are using SOSL.  This is a dramatic change in functionality, as we only want to search 3 text fields and SOSL with All Text Fields retrieves unexpected results for our users.  This appears to be a bug in the latest release.  
This is happening on all our Skuid pages where we use a reference as we do not use SOSL for anything.  

Actual culprit causing auto complete to freeze for a reference is adding specific custom “Search Fields” for that look up. Checking SOSL checkbox “removes” all those custom fields and performs search on all name fields / all text fields etc. which helps freezing to stop. 

We have heavily used custom “Search Fields” and SOSL is unchecked on many pages. Auto complete for all those fields is not going to work because of this bug.  

Hi Folks~

Sorry for any inconvenience this may be causing you! We are able to reproduce this issue in our org as well and have brought it to our product team. We will update you when a fix is available that addresses this issue.  

Thank you for alerting us of this issue!!!

We are unable to specify custom fields for search boxes / filters for table components as well. All I see is a list of lookup fields there. 

Hi folks~

We’re almost ready with the fix that addresses this. Be on the lookout for an update to this community post next Tuesday/Wednesday!!! 


Thank you! 

Great, Do we know if it’s going to be today or tomorrow?

Hello Skuid Community ~

Thank you for your thoughtful suggestion! Skuid listened to your concern and has implemented your idea in the new Brooklyn 10.0.5 and 9.5.12 release which is now available on the Skuid Releases page.

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.