red outline no longer showing on required fields on table

We are in the testing phase at the moment and have noticed with the latest version of Skuid in Sandbox (9.5.5) required fields on tables no longer have the red outline

This is not a problem in production which is still using an older version of Skuid (8.15.15)

Does anyone have any idea why this is happening?

Hello William

I’m on 9.5.5 too and my required fields still get a red outline (See attached screenshots). Could it be a setting in your theme maybe?

Skuid Version

Required field: Shipping City

I could only imagine a setting in your theme or an inline CSS. Could you check this?

Thanks,

Janick

Hi Janick,

I just created a brand new page using the default theme Lightning Design. It does not have any extra css and the field will not show the red outline, same result in both Chrome and Firefox

update: I changed from Lightning Design theme to Modern theme and the fields are now showing the red highlight as per usual. I used Chrome to get the Lightning Design CSS and have linked to the pastebin of the CSS https://pastebin.com/PT6ZR075

William,

If you want to use the Lightning theme but WITH red borders, you’ll have to clone (because you cannot edit standard themes) and edit the settings. Here’s the “compose themes” article: http://help.skuid.com/m/25162/l/376413-compose-themes

Chose the Lightning theme as “Base Theme”, then Launch the Theme Composer.
In the left side menu, chose the component (probably field editor?). Then chose “Field Input” on the right side menu and scroll down to “Border (required)” and configure as desired.

I hope this does the trick,

Janick

Janick,

While cloning and editing the theme is a workaround it still does not explain why in our production environment the same page using the same theme has the red outline around required fields whereas in sandbox the outcome is different, the only difference is the version of SKUID (8.15.15 in prod and 9.5.5 in sandbox)

I can see there were changes to the CSS between SKUID versions and suspect the new CSS may be the culprit

Any reply to my latest comment?