Recordtype based picklist values not working in SKUID page

We have a Picklist which has recordtype based values to show up on a SKUID page. It is showing all values from the picklist irrespective of the recordtype. 
1. User’s profile has API Enabled permission
2. User has access to Recordtype
3. User has access to the picklist field
4. No errors found in console while loading the page
5. Correct recordtype assigned to the record
6. Cache cleared

Anything else we missed here?

Hmm, it sure seems like you hit everything. What version of Skuid are you on? Have you updated recently? Has this functionality worked in the past and just stopped working now, or has it never worked?


Hi Amy, 

Thanks for your response!

We are in Brooklyn Iteration 6 (9.3.6) release, and this is a new page created now. 
We have other pages which are showing picklist values based on recordtype, but they were created in older verisons. Apparently, the problem is with Brooklyn Iteration 6?


Please consider it solved!!!

There’s some problem with model generation in SKUID. I deleted existing model and recreated with same name and same conditions, its working now. (I tried cloning the existing model and deleted old one this also didn’t work). So, only solution is to replace old model with new model.

Thanks Amy for sparing your time to look into the issue.