Read only table showing row actions check boxes

Recently, I’ve noticed some of my read only tables with no mass actions still show the select all/row select check boxes. Checking them doesn’t do anything. I have not found a pattern as to why it shows up on some tables but not others. Here’s my XML for the table. The check boxes show up with and without the CSS class, so I know its not that.

<pre><skootable showconditions="true" showsavecancel="false" showerrorsinline="true" searchmethod="server" searchbox="false" showexportbuttons="false" pagesize="all" createrecords="false" model="Refunds" buttonposition="" mode="readonly" uniqueid="sk-24P_5z-4235" emptysearchbehavior="query" cssclass="hideFooterMaster">
 <fields> <field id="CheetahBMS__Amount__c" decimalplaces="" valuehalign="" type=""> <label>Refunds</label> <summaries> <summary>sum</summary> </summaries> </field> <field id="CreatedDate"/> <field id="CreatedBy.Name" valuehalign="" type=""> <label>Created By</label> </field> </fields> <rowactions/> <massactions usefirstitemasdefault="true"/> <views> <view type="standard"/> </views> <searchfields/> <renderconditions logictype="and"> <rendercondition type="fieldvalue" enclosevalueinquotes="true" fieldmodel="Refunds" sourcetype="modelproperty" nosourcerowbehavior="deactivate" sourceproperty="hasRows"/> </renderconditions> </skootable></pre> 

Whenever you have column summaries on a table,  the check boxes will appear.  When you select some of the rows - the summaries will update to show the summary just for the selected rows.  Nice.  But sometimes not… 

You can get rid of the checkboxes in CSS.  Add a class to your table and add this css to your page:  

.yourClassName table.nx-skootable-data input[type=checkbox] {
    display: none;
}

Thanks for the explanation Rob. Cool feature, not sure how I didn’t notice that previously.