Problem with picklist in Mass Update

Greetings,

We’re having a small problem with a picklist when trying to attempt a Mass Update. There are four other picklists that the user can select from, and 3 of them work as desired. There is one however, that only shows “-- None–” when the user selects that particular picklist. When the user tries to inline edit a row, then the user can select items from that picklist.

Thanks for any help.

Also, after some investigation, it seems the problem might be caused by the fact that this picklist is dependent on the value in another picklist.

Yes, dependent picklists are tricky. Is the field that the picklist is dependent on in the model?

Yeah, that’s one of the first things that I checked. I also included that field in the table row just to be sure, and with the same result.

This problem hasn’t been hasn’t resolved or has regressed. I’m on 9.5.4. Tried on both Chrome and Firefox.

Multi picklist works when editing row, but not in Mass Update. Also, I don’t have any recordtypes.

John, Pat, and Matt,

I’m able to reproduce the issue you’re seeing with mass updating dependent picklists (or multipicklists). I’ve notified our developers of this issue, and I’ll let you know what they decide about it. Normally I’d just say we’ll let you know when it’s fixed, but this instance is interesting. I can see why you wouldn’t be able to mass update two records if their controlling fields were different, but I agree it would be nice if you could mass update fields if their controlling field was the same. All that to say, I don’t want to incorrectly say our devs will fix this when I’m not sure if this is an issue or a new feature request (though maybe I’m splitting hairs since I agree that the current setup isn’t ideal - it looks like you can update them but you can’t). I’ll keep you updated, though, and let you know how we choose to handle this :slight_smile:

Thanks Amy