Problem with overriding SF tab page

I’m struggling with doing any page overrides in SF. I’m following the tutorials on this (here) but am getting the following error messages when I get to adding a new VF page (step 4 in the tutorial) and use the code for no page assignments and custom objects.

Error: apex:page is required and must be the outermost tag in the markup at line 1 column 1

I couldn’t find anyone in the community here with the same issue but found people on the SF page with the same error and some suggestion that this is a browser issue. I tried firefox with no luck.

I tried again before posting and am getting different messages, but not sure why (did not change anything). Here is the new error message I’m getting:

Error: Unknown property ‘redirect’ referenced in IDFqueue

Here’s the markup I’m using: (Skuid page name is IDFqueue and the Object is Innovation_Disclosure__c)

apex:page standardController=Innovation_Disclosure__c recordSetVar=cextensions=skuid.Redirects action={!redirect}?page=IDFqueue></apex:page>

Please Help :frowning:

PS: I’m also curious how the markup would change if the page had several models involved

PPS: Disclaimer: this is my first forray into doing anything with the VF pages section of SF

We’ve usually seen this problem when you are trying to override the tab page of a managed package. These packages don’t like it when we try to call their controllers and you get that sort of strange error message.

The way we’ve been able to solve the problem is by creating a visualforce tab and then using our most simple form of override code where you merely call the page directly without any controller. The code looks like this:

<apex:page showHeader="true" sidebar="false"> 

<skuid:page page="IDFqueue"/>

Let me know if this works for you.

Thanks Rob, that sort of worked.

The page now initially works, but when I click on any of the selections on the queue list, things go south. A second header (same as above) loads on the right of the queue list and the record tries to load but never does.

About your comment about a managed package. I’m not sure what that exactly means but I don’t think that’s the case.

Ok.  We might want to go to ground zero.  I was going down a path thinking you were trying to override the tab display of an object included in a managed package. (somthing you aquired from the app exchange).  But the form of VF syntax I gave you doens’t play well with the page includes that queue’s require.  So,  I’d go back and work through this tutorial.

It looks like you are missing some quotes in your VF code from the original post. 

Sorry for the run around.  Overrides are some of the more complicated pieces of getting Skuid to work just like you want. 

Success! I finally got it to work, and I think you’re right. It seems it was the missing quotations. 

You might want to add these to the tutorial example for the custom object (last part of Step 4) as I think that’s where I went off on this tangent

Thanks Ahmed. I’ll look into that. 


The reason that your overrides were not working was probably a copy/paste error. The following that you added will not work because it is invalid syntax:

apex:page standardController=Innovation_Disclosure__c recordSetVar=cextensions=skuid.Redirects action={!redirect}?page=IDFqueue></apex:page>

Change it to be the following and it should work:

<apex:page standardController=“Innovation_Disclosure__c” recordSetVar=“c” extensions=“skuid.Redirects” action=“{!redirect}?page=IDFqueue”></apex:page>

Seem to be having the same issue. After changing the detail view code, I can view it once. When I try getting back to the detail page it comes up as a blank screen. Any ideas? Thanks

Are you also in a Queue?  Does it work in preview mode but not when you override the tab and use the salesforce navigation? 

That’s correct. Works in preview only. And additionally now not sure what I’ve done but I can no longer select a visual force page for my custom object