Problem when using Invocable and Run Data Source action on Skuid page


In LX mode and Skuid, we are using the Invocable and Run Data Source Action to call the apex class. This apex class will call to an outside server (using HttpRequest and Post ) to sync data between the external data from another server and Salesforce. But, it didn’t sync successfully. However, when we tried to call directly from the apex class, not on Skuid page, we can sync successfully. 

We couldn’t find out the root cause why on Skuid page, we have not managed to sync data successfully.

Please help to advise us for this problem. 

Thank you.


I recommend you open the console on the browser and look at the network log.  Filter for the XHR responses.  You should see an apex remote line where you called your invocable.  Double-click on the line to see the response.  This may give you some information on the problem.

Having said that, I also recommend you check any inputs to your invocable.  I ran into a similar problem that you had and found that I mis-typed the merge variable for one of the inputs.  Sending a null or undefined into an input prevented the invocable from working.