Problem initializing a component of type skuid__labelInput

I have been editing a skuid page today and all was going well until I got this error on preview:

There was a problem initializing a component of type skuid__labelInput: Invalid XML:

I searched the community and google and am not finding anything with the term “skuid__labelInput”

I also reviewed the XML editor and it does not have the normal red Error message in the upper right to indicate that the XML is invalid.  There are also no lines in the XML with the Red square with the X at the beginning of the line to indicate where the issue is.  

Does anyone have any suggestions on how to troubleshoot the issue?  (Other than restoring an earlier version where it wasn’t occurring.)

I am using the V2 Composer on Spark 12.2.8 (latest version)

Hi CM, it looks like you shared something in your first post, but it’s not displayed properly. Was it the XML? Please try again to share it in your next reply.


I didn’t try to share anything, not sure why it left such a big white space in my original post.  It did that in another post I submitted as well.

Additionally, the page will load with using the classic preview; however, when I preview the page using the Aura review, I get this error:  

Sorry to inturrupt

This page has an error. You might just need to refresh it. [There was an error rendering a Skuid Page component for page undefined TypeError: Cannot read property ‘file’ of null] Failing descriptor: {markup://skuid:page}

when I close the error message, the page will not load.  Refreshing does not seem to help resolve the issue.

Thanks CM, if you have an earlier where the issue wasn’t occurring, you could use the diffchecker to compare both page XML versions to find the difference. Maybe that sheds more light on which part of the XML is relevant for the investigation:

  1. Go to:
  2. Enter the page XML of the version that still worked on the left
  3. Enter the page XML of the broken version on the right
  4. Click “Find Difference”


I was able to find the culprit, but I’ve go no idea why its happening. We have a field on the Case object called Care_Plan_Substatus_Reason__c that is a picklist field. (There is nothing particularly special about the field, and we haven’t overridden the field metadata in skuid). Whenever I include this field in a Form component, I get the skuid__labelInput: Invalid XML Error Message. Once I remove it, everything is fine again. I need to be able to include this field in the Skuid Page I’m working on, but I’ve got no idea how to work around the issue. Any Ideas?

This snippet of the XML works:

This smippeof of XML does not work:

Here is a diff checker image that shows that the only difference is the inclusion of the Care_Plan_Substatus_Reason__c field.

Thank you for the details. Sounds good that you could narrow down the issue already. I couldn’t reproduce the issue, based on the details we know by now.
Since it looks like you aren’t using the meta data override, nor using Skuid’s “Custom Label” in the Form field options, but still get a label error, please check the following:

  • I'm wondering how your "Field Label" in the Salesforce setup looks like (where you set Field Name and Field Label in the custom field settings)?
  • Please also check in Salesforce Field settings the "Help Text" of the field "Care_Plan_Substatus_Reason__c", what does it contain?
  • If you compare Salesforce settings of the Fields "Care_Plan_Substatus_Reason__c" and "Care_Plan_Substatus_Reason_Other__c", do you find any helpful difference?
I'm testing in version 12.2.8 and I added a custom field called "Care_Plan_Substatus_Reason" to my Cases object in Salesforce, so that my XML looks similar to yours, but it works fine:
<skuid__form showErrorsInline="true" model="Cases" uniqueid="sk-3z6o-2898" mode="edit">
<section title="New Section">
<skuid__field id="Status"/>
<skuid__field id="Care_Plan_Substatus_Reason__c" showHelp="true"/>