Prefill filter-set 'field' values?

Working on campaigns, and making a table to add items (in this case NPSP Allocations) to a ‘project campaign’ (custom record type)

I have a filter on the nsp_Allocation__c model for ‘GAU Fund’, and CloseDate on the Allocation->Opp->CloseDate field.

I’m looking to prefill the filter-set ‘fields’ with default values from the Campaign. A ‘GAU Fund’ field, and Allocation->Opp->CloseDate date range.

I’ve tried setting the model condition fields via an action when I show the table/filter-set. I it seems that the GAU fund lookup field populates the filter-set field, but I can’t get the dates to prefill. (I say seems, because I had it working but can’t get it working again)

Is this possible? I looked thru the Skuid Skool filters lesson, but didn’t see anything.

So lets start with simple setup.

First your filters will have to be configured to “Pick options and conditions – Manually” where you select specific Filterable conditions on your model.

Then those conditions should be set up as “Filterable Default On” in the models, and you can source their default values from another model on page load. Just make sure this second model loads before the allocation model.

The default value of the condition should be represented in the filter control on page load. (At least this how it SHOULD work). And you should be able to use the filter to update the conditions and change the data displayed.

If this is all too simple - and has failed for whatever reason - lets keep talking. I think there are other options.

Honestly, I’m unclear as to what your asking be done.

As i tried moving on, I realized I’ll need to ‘read’ the filter-set options in an action for use in another query for mass-actions (btw, I can’t find any actual instruction/demo on setting up mass-actions. Lots of talk about mass-actions use context, but no example of how I apply that context to actual individual actions)

I was unable to figure out how to read-back the filter-set field values.

I ended up making my own ‘filter-set’ using UI-Only Fields, and have a similar problem using a UI-Only reference field. I can set the reference value, but not actually search for one or display it in the UI-Only field.

The attached image shows what I’m trying to do. The ‘filter’ part could be this ui-only roll-your-own filter or the filter set.

I have a header button called “Import Allocations” which shows the bottom “Import Allocations Table”.

I’m trying to prefill the filter options with the setup from the actual campaign. I can easily move the Start/End date into the UI-Only fields (I forget what was happening with filter sets)
I can move the “Linked GAU Fund” into the “GAU Fund” UI-Only Reference field, and apparently it loads correctly because the “Apply” button does the query correctly.

But searching or displaying the UI-Only reference GAU Fund field doesn’t work (or display the field value).

I’ve not found a good explanation of how to actually setup the UI-Only Reference field. Like what does 'Relationship field name" in the Reference setup mean/do. The tooltip is probably very helpful if you already know what it means.

The intent is to prefill the search fields, but allow the user to edit them. This particular process is to convert previous donations to new project campaigns, where previously they were just noted by different text in the “Acknowledgment” field.

My expected action is that the UI-Only Reference field would let me select the GAU fund npsp__General_Accounting_Unit__c just like on a form. But it doesn’t work that way. Clicking the Search magnifying glass button, pops up a selector for the record (a not very customizable view), BUT, selecting one closes the pop-up and opens a dropdown for the Reference field listing all the options all over again. Then if I select one, I get ‘Type Errors’.

I apologize for the meandering/change of issue.

It would seem that all this might be for naught, as apparently, you can’t use javascript snippets for mass actions?

What I’m trying to do is select a group (from an aggregate query) of records to import.
I use select the ‘records’ and mass-actions to import those.

It needs to do a query for each row (since it’s an aggregate query) to get the individual records of the aggregate and update a field on those rows.

Easy-peasy with getSelectedItems.

  • Loop thru the selected rows
    • Update a model to query the aggregate (in this case it’s the Fund+StartDate+EndDate+Acknowledgement )
    • Run the Query
    • Loop thru each row in the query model updating the single field linking to the campaign.