Popup with page include works fine in preview, but fails in normal use

sorry to seem stuck on the same topic but I more “page include Uncaught TypeErrors” - in this case the included page loads fine when previewing, but once I start using it with a visual force page deployment, I get uncaught Type Errors. I’ve pasted screenshots below. I’ve triple-checked that pages are in the same module, swapped them out & back in again, but it doesn’t seem to make a difference.

The most frequent error I get is:

Uncaught TypeError: Cannot read property ‘length’ of undefined
ActivityReminder._checkScheduleUpdates

Screenshot for Preview page working ok:

Deployed page fails and renders standard salesforce header instead:

Any help is greatly appreciated. Thanks, Greg

Update: I got this to work using different syntax in the visual force page.

The incorrect syntax I had previously was:

<apex:page standardController=“CustomObject__c”>
<skuid:page page=“PageName”/>
</apex:page>

The correct syntax which worked is:

<apex:page action="{!redirect}&page=PageName" extensions=“skuid.Redirects” standardController=“CustomObject__c”>
</apex:page>

Hi Greg,

It is possible to use Page Includes with the skuid:page component Visualforce Page syntax, but you have to follow the steps outlined in this tutorial:

http://help.skuidify.com/m/page-assignments-and-overrides/l/201793-using-the-skuid-page-visualforce-…

Zach

I have follow the tutorial and with the Override an object’s View action using page assigments the included page in a popup does not work

Update: confirmed greg case. If the apex page is with

<apex:page standardController="Site__c" recordsetvar="c" extensions="skuid&#46;Redirects" showChat="false"
showHeader="false" sidebar="false" standardStylesheets="false"
action="{!redirect}?page=SiteWip">
</apex:page> 

works

If I change he Visualforce page to:

<apex:page standardController="Site__c" recordsetvar="a" extensions="skuid&#46;Redirects" showHeader="true" sidebar="true" readonly="true" docType="html-5&#46;0" action="{!IF(canUseSkuid,'',redirect)}" title="{!$ObjectType&#46;Site__c&#46;labelPlural}"><skuid:page page="SiteWip" /></apex:page> 

The page include does not work, same error as greg

Any insights on this?

Do you have the local version of the Include VF page - as described in the prerequisites section of this tutorial

ok… shame on me… I thought I did it.

It’s working the included page now

Cool!