Picklists not displaying in Lightning App

We have a Skuid page in a Lighting App and for some reason some of our picklists are not displaying values when they are clicked on. We’ve verified that users have permissions to the fields, field level security is good, and have upgraded to the latest release. It’s happening when we go to create a new record in a table (but only on some tables) and in a sidebar component we’re using for the log a call functionality. If we override the field metadata, we can get the values to appear but the field renders tied to those values aren’t being respected…

Anyone have any idea as to what’s happening?

The user and all related content has been deleted.

Hi Peter, I’m working with Matt on this.

Here is an example of a simple page showing a picklist for industry:



















If we click preview, we get what we expect, the picklist with options for industry. If we deploy this page in lightning (tried both using the skuid page component as well as a lightning component, it says “none” with no options.

Lightning:

Same page via preview:

The user and all related content has been deleted.

The plot thickens.  The console is challenging in lighting.  I could use some pointers on how to pull errors out of a lightning deployed skuid page.

In your org, do you have record types enabled?  Can you try adding record types if not see if it still works?  Record types and picklists have not been my friend in the past, so I have a suspicion there may be a quirk there.

The user and all related content has been deleted.

The user and all related content has been deleted.

The user and all related content has been deleted.

When using the debugging instructions, I don’t get a “highlighted skuid variable” in the result, so I’m not able to get to the model.  Can we have a call on this?

The user and all related content has been deleted.

Yes, the skuid.model.map() shows all the picklist field options.  It is a basic field editor component though, how do we get the fields in the model into the ui?

Paul, does the user viewing the page have the “Skuid Page Viewer” permission set assigned to them?

This user has the ‘Skuid Admin’ permission set assigned to them.  I presume that is sufficient and a superset of the page view perm set?  

Yep, that should be good. Is Industry dependent on any other fields? Like, is there any other Controlling Field on Account which restricts the values for Industry?

No, but record types are enabled, however all fields are in the record type.  Also, the fields do show up in skuid.model.map(), just not on the page when deployed inside lightning.  Previewing the page does show all fields in the picklist.

Also, Industry is just a test field to demonstrate the error on a native field so you can reproduce - all picklists were showing this behavior on the real page, but some are custom fields.

Hi Paul,

Can you check to make sure the affected picklists are present on each record type’s Page Layout, in the object’s page layouts? My engineers tell me this is necessary for Skuid to be able to pull in the picklist options successfully via Salesforce’s Lightning API. 

Have tried this with one picklist on one page layout related to the account. No change seen.

Hi, we had the same issue. At the end it was a security issue. Solution for us was to add salesforce recommended ip range(s) to the users profile settings https://help.salesforce.com/articleView?id=000321501&type=1&mode=1

Apart from picklist i also see the problem with checkboxes, the value are not persisting
we recently moved to lightning. Not clear how security setting will impact the UI.
if we change to classic mode, no issue with these elements

Hi Andre,
we have the same problem where the picklist field values display doesn’t allow users to select, values are visible when they click on edit pencil icon but page doesn’t allow to select the value and list collapses when we move the cursor to select the value from edit icon.

Issue is happening in the lightning mode, same with checkbox field.